Bug ID 1199210
Summary Firefox 99 no longer plays video content due to Tumbleweed FFMPEG / openh264 incompatibility
Classification openSUSE
Product openSUSE Tumbleweed
Version Current
Hardware x86-64
OS openSUSE Tumbleweed
Status NEW
Severity Normal
Priority P5 - None
Component Firefox
Assignee factory-mozilla@lists.opensuse.org
Reporter jphands@gmail.com
QA Contact qa-bugs@suse.de
Found By ---
Blocker ---

About 21 days ago, I reported a bug (
https://bugzilla.mozilla.org/show_bug.cgi?id=1764436 ) to the FireFox team,
after a Tumbleweed update caused FireFox to stop playing some video content.  
Other browsers like Brave or Opera worked just fine, leading me to suspect
Firefox.  I worked with the FF team to run various tests and their eventual
resolution is "wontfix" because the problem actually seems to be some packaging
issue with FFMPEG and OPeH264...perhaps a version mismatch.

One of the FF developers said "To fix the problem, you need to install the
exact same version of https://software.opensuse.org/package/libopenh264-6 that
was used to build OpenSuse's ffmpeg-5."  The mozilla bug link above gives the
full story.

I have been unable to get Firefox to play video content, no matter what
combination of FFMPEG and Openh264 I've tried, but this area isn't my strength.

The FF people recommended that I open a bug with Tumbleweed, and perhaps
together, the bug can be resolved.

I'm available for any testing or experiments...just let me know.


Operating System: openSUSE Tumbleweed 20220503
KDE Plasma Version: 5.24.4
KDE Frameworks Version: 5.93.0
Qt Version: 5.15.2
Kernel Version: 5.17.4-1-default (64-bit)
Graphics Platform: X11
Processors: 24 ��� AMD Ryzen 9 3900X 12-Core Processor
Memory: 47.0 GiB of RAM
Graphics Processor: AMD DIMGREY_CAVEFISH

You are receiving this mail because: