I have a question/problem with Perl packages and BuildRequires when
building for SLES(SP2).
The problem comes up with multiple packages when trying to build them
for SLES, let's look at perl-HTTP-BrowserDetect from
devel:languages:perl for example.
The spec files includes:
BuildRequires: perl(Module::Build) >= 0.3601
and the build log clearly states (see
that it is being installed:
but still, the build fails with:
Module::Build version 0.3601 required--this is only version 0.280801 at
Build.PL line 5.
As far as I understand, "Module::Build" v0.280801 is already installed
by default under SLES11SP2 and the newer required version 0.3607 is not
found OR the older version is found first by the script "Build.pl".
A second example would be "perl-POE-Test-Loops" which requires a version
of Test::More/Test::Simple >=0.94, but this is not found although
installed (i.e. only an older version is found), see log here:
How do I circumvent this problem?
Thanks for your help!