Comment # 5 on bug 1143725 from
(In reply to Dario Faggioli from comment #1)
> Note that is doesn't look like it could be a "container specific" thing. In
> fact, I tried to setup a "traditional" ARM64 chroot, on the x86 host, again
> using qemu-linux-user and binfmt (basically, how it is described here:
> and I run into the same issue.
> BTW, adding to Cc, as this is about QEMU.
And I was wrong here. A "traditional chroot", works:

$ cat /proc/sys/fs/binfmt_misc/qemu-aarch64
interpreter /usr/bin/qemu-aarch64-binfmt
flags: P
offset 0
magic 7f454c460201010000000000000000000200b700
mask ffffffffffffff00fffffffffffffffffeffffff

# chroot src/rootfs/ARM/openSUSE/Tumbleweed/ /bin/bash
Palanthas:/ # uname -a
Linux Palanthas 5.1.16-1-default #1 SMP Wed Jul 3 12:37:47 UTC 2019 (2af8a22)
aarch64 aarch64 aarch64 GNU/Linux

So, this, together with Comment 4 , seems to suggest that it is something
related to the interaction of qemu-aarch64-binfmt (from qemu-linux-user) and
docker (or some other container-related component)

You are receiving this mail because: