Yes I had terrible trouble with lvm, All the kernel updates break the lvm mappings leaving the system in an unbootable state...

as for rescue, the only way I found was to reinstall over the top of the existing installation, this would put the old(default) kernel back, and allow you back into your system.

On Sun, 2004-07-04 at 17:58, Darrell Shively wrote:
Hash: SHA1

Hi Neal and Joel:

I just ran into this myself.  After allowing YOU to update my kernel, my 
system won't boot.  When I tried to use Rescue to see why, it says "Is 
device-mapper missing from kernel?"

Well, I don't know.  Is it?  I foolishly assumed rescue would let me access 
my LVM filesystems....

This confuses me.  The installer is obviously able to use LVM: that's how the 
LVM partitions were created.  However, tried to use Manual Installation to 
pre-load the LVM module (aka device mapper?) and could not find it in the 
list of available modules.  Crap!

I see there was no reply to this on the list.  Did either of you find a 
solution?  It would be kind of SuSE to make a rescue CD image available with 
the LVM modules.

Good thing I kept my old 9.0 image around...

   Thanks for your time,
	- Darrell

On Friday 21 May 2004 04:19, Neal D. Becker wrote:
> On Thursday 20 May 2004 08:41 am, Neal D. Becker wrote:
> > On Thursday 20 May 2004 8:25 am, Joel Wiramu Pauling wrote:
> > > Hi Neal... Yes I had similar problems with LVM...
> > >
> > > My Solution to all these woes Wether using or raid/lvm: Turn of raid
> > > functions from the sata controller (so it's now just an sata
> > > controller)
> >
> > Sorry, I should have mentioned I am not using hardware raid.  I am using
> > LVM2 stripping (software raid).  The controller is promise.  I could
> > connect to the via instead, if it would matter.
> >
> > I don't know which controller would be better.  I understand the via is
> > more directly connected to the cpu, but the promise emulates scsi, which
> > might be better (well, it looks cooler anyway:).
> One major problem is, the Suse 9.1 rescue mode is *missing the LVM
> drivers*. Now that my system is repaired, I just tried to boot in rescue
> mode and it doesn't work.  It doesn't mount the LVM array, because it
> appears drm-mod is not present.
> If my diagnosis is correct, this is a serious oversight.  I hope Suse will
> issue an update to fix this.
> -------------------------------------------------------

- --      "Perfect! ....what am I doing?"
                      -- Washu
Version: GnuPG v1.0.7 (GNU/Linux)