Mailinglist Archive: opensuse (389 mails)

< Previous Next >
Re: [opensuse] redis
On Sun, 03 Mar 2019 19:22:41 +0200
auxsvr <auxsvr@xxxxxxxxx> wrote:

On Sunday, 3 March 2019 17:51:03 EET Dave Howorth wrote:
I just installed redis 4.0.10-lp150.3.3.1 from openSUSE Leap 15.0
repository but I can't figure out how to start/use it.

So how do I get it working? Anybody know?

Have a look in /usr/share/doc/packages/redis/README.SUSE.

Thanks for the pointer.

I don't understand why it says (step 2) to change these settings.
What's wrong with them as is?

I followed the rest of the instructions but using 'default' instead of
'otherapp' and I found some steps were already done.

I don't know (also step 2, stupid step numbering) whether I want to use
redis in combination with apache. emoncms does use apache and it does
use redis, so does that mean I am 'using redis in combination with
apache' or not?

Oh, and lots of the steps in the readme are shown with a $ prompt but
need to be run as root.

So when I got to the end of the readme:

# systemctl status redis
Unit redis.service could not be found.

# systemctl status redis@default
● redis@default.service - Redis
Loaded: loaded (/usr/lib/systemd/system/redis@.service; enabled;
vendor preset: disabled)
Drop-In: /etc/systemd/system/redis@default.service.d └─limits.conf
Active: failed (Result: exit-code) since Sun 2019-03-03 20:35:12
GMT; 5min ago Main PID: 30742 (code=exited, status=1/FAILURE)

Mar 03 20:35:12 acer-suse systemd[1]: redis@default.service: Unit
entered failed state. Mar 03 20:35:12 acer-suse systemd[1]:
redis@default.service: Failed with result 'exit-code'. Mar 03 20:35:12
acer-suse systemd[1]: redis@default.service: Service RestartSec=100ms
expired, scheduling restart. Mar 03 20:35:12 acer-suse systemd[1]:
Stopped Redis. Mar 03 20:35:12 acer-suse systemd[1]:
redis@default.service: Start request repeated too quickly. Mar 03
20:35:12 acer-suse systemd[1]: Failed to start Redis. Mar 03 20:35:12
acer-suse systemd[1]: redis@default.service: Unit entered failed state.
Mar 03 20:35:12 acer-suse systemd[1]: redis@default.service: Failed
with result 'exit-code'.

So I still haven't got it to run.

I don't understand why I don't use YaST to install it and then it's
running? And if I need to tweak it then fine but at least it works out
of the box. That's what happens on the competition (ubuntu or Rpi) AIUI.

--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups
References