Mailinglist Archive: opensuse (626 mails)

< Previous Next >
Re: [opensuse] Re: 'mv' a read-only directory doesn't work...why not?
On 09/11/18 04:02 PM, Linda Walsh wrote:
On 11/9/2018 11:10 AM, Aaron Digulla wrote:

To "emphasize the point":  1) I can do a 'cp -a a/dir1 b/' which
works.  Since they are
  on the same device, even hardlinks will be duplicated.
2) I can then follow-up with 'rmdir a/dir1', which also
  works (no warning like when removing a file):
 > rm a/file1
 rm: remove write-protected regular empty file 'a/file1'?

I.e. the exact same actions 'mv' would do if I was copying
between devices.

Err no. The actions have the same result but use different operations.
To get to the backside of a house, I can go left and right (and even
over the roof). Same result, different ways.
----
    Except the copy+delete is exactly what 'mv' does
when the target is on a different file system.

As usual, Linda, spot on.

But when on the same device it does a link/unlink.

That's an important difference!


Thanks for response...I guess I'm unhappy with the inconsistencies and
arbitrariness.

I don't know.
The way you present it, it is, and I don;t think it is fair to compare Linux
with CygWin.

But whenever I've faced this on my machines and I've drilled down step by step
I've always found out there was something I was missing, something I was
supposing that wasn't so.
I can't look over your shoulder for the details; yes AS YOU PRESENT IT it is
inconsistent.

--
A: Yes.
> Q: Are you sure?
>> A: Because it reverses the logical flow of conversation.
>>> Q: Why is top posting frowned upon?


--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups