Mailinglist Archive: opensuse (1108 mails)

< Previous Next >
Re: [opensuse] Leap-15.0: how to switch to single user mode?
* Mark Hounschell <markh@xxxxxxxxxx> [08-22-18 09:58]:
On 08/22/2018 08:55 AM, Patrick Shanahan wrote:
* Mark Hounschell <markh@xxxxxxxxxx> [08-22-18 08:49]:
On 08/22/2018 07:19 AM, Josef Wolf wrote:
Hello,

if i give the command "telinit s" (on VT1 of course) the screen is
blanked and
only a cursor blinks at the top left corder.

If I use CTL-ATL-F1 to switch to VT1 again, I see the last contents of
that
VT1. The last command I gave (the "telinit s") just hangs. I'd expect
either a
root shell or a prpmopt to type the root password to get a shell.

What gives? How can I switch to single user mode?


#init s

Works just fine here on 15.0.

but the problem appears to be the different approach, "booting" to init
(1|S)/runlevel 1/telnet (1|S) and "changing to" init (1|S)/runlevel
1/telnet (1|S)

and your results fail to mention your path.


#init s implies changing from a runlevel other than s to s. In this case
runlevel-5 to single user. Booting to single user mode by appending the
command line with an "s" works fine here also though.

and I agree with the "implication", just not how it is achieved, ie: from
a running system (change to) or from a "dead" system (boot up).

--
(paka)Patrick Shanahan Plainfield, Indiana, USA @ptilopteri
http://en.opensuse.org openSUSE Community Member facebook/ptilopteri
Registered Linux User #207535 @ http://linuxcounter.net
Photos: http://wahoo.no-ip.org/piwigo paka @ IRCnet freenode

--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups