Mailinglist Archive: opensuse (1108 mails)

< Previous Next >
Re: [opensuse] Using e2fsck in, eg, Leap 15.0
  • From: Per Jessen <per@xxxxxxxxxxxx>
  • Date: Wed, 22 Aug 2018 13:46:05 +0200
  • Message-id: <pljidt$a1d$1@saturn.local.net>
Carlos E. R. wrote:

On 2018-08-21 14:06, Per Jessen wrote:
Carlos E. R. wrote:

On 2018-08-21 13:55, Per Jessen wrote:
Carlos E. R. wrote:

On 2018-08-21 11:34, Per Jessen wrote:
Basil Chupin wrote:

But the simplest way in the past was to do what I wrote in my
opening post. And if only someone could tell me what now
replaces 'mount -o remount, ro /dev/hdXY' in systemd :-(.)

Nothing, afaik - it's a perfectly valid mount command.

You wrote initially "it doesn't work" - exactly what happens?

I tried it on a running system and of course it says:

office38:~ # mount -o remount,ro /
mount: /: mount point is busy.

What happens when you've done "init 1" and you try the remount?

IIRC, same thing. Busy. Long time since I last tried.

Just tried it, you're right.

Boot up into single user mode, and it works though.

What level is "single user mode"? :-?

I thought that was "init 1".

I boot up with "init S". I have never used "init 1".

see "man init", Looks like S and 1 are the same on systemd.

But Basil (and you?) says that fsck can't check root on init 1, and
you say you can on init S, so they are not the same.

According to the man page, they are. (man init).
Maybe the difference that I booted up into single user mode ? I presume
Basil issued a 'init 1' from a running system.



--
Per Jessen, Zürich (27.7°C)
http://www.cloudsuisse.com/ - your owncloud, hosted in Switzerland.


--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >