Mailinglist Archive: opensuse (1108 mails)

< Previous Next >
Re: [opensuse] kernel versions
On 08/17/2018 06:13 AM, Anton Aylward wrote:
Don, please trim your replies.

On 2018-08-16 11:23 p.m., don fisher wrote:
anges at
https://www.phoronix.com/scan.php?page=news_item&px=Linux-4.18-Released
and see if any affect you.

I tried the 4.18.0-1.g6e2c3e0-default kernel and it failed.

Well that's unhelpful.
HOW did it fail?
Did it fail to load? Did it fail to start some service or application?
Did it fail to let you use some port?

Is this a 32-bit machine you are trying with a 64-bit kernel?

But the
4.4.140-62-default, part of the 42.3 distribution, runs perfectly.

And what constitutes 'perfectly'?
Do all your ports work perfectly?


I wanted to
start there and install later kernels until I see the failure and isolate the
problem that I am experiencing. As I mentioned, there are some things I do not
understand about this laptop's hardware. And with a 13" screen it is hard for me
to see details in a dump.

There are plenty of ways to dig into the hardware starting with the simple "ls*'
family:
lsb-release lscpu lsipc lsmod lspci lsusb
lsdev lslocks lsns lsattr lsblk lsinitrd
lslogins lsof lsscsi

Using the kernel boot options 'splash=verbose showopts' -- and yes this all
documented -- some specific like this
https://doc.opensuse.org/documentation/leap/startup/html/book.opensuse.startup/cha.trouble.html
and some more comprehensive:
https://doc.opensuse.org/
/...../Documentation/kernel-parameters.txt
...
will let you see what is going on as you boot. If this goes by too fast, then
you should turn to, of course, the logs, and/or make use of the 'dmesg' command.
I would also advise enabling journald for the last 500M of permanent store.
Again this is documented, start with the man page.

As for you 13" screen: I resume you have a TTY or video port?
You can plug in another screen and have the boot messages appear there; it's
just a kernel boot time command line parameter.
I think it is "console=" but I've never had to use it.
perhaps others here can advise.
Press 'e' to be able to edit the GRUB and add it.
https://doc.opensuse.org/documentation/leap/startup/html/book.opensuse.startup/cha.boot_parameters.html

"Works perfectly" was meant to say there have been no significant errors found compared to my other laptop. In terms of speed, I have seen 500GB transfer rates under rsync between the two SSD drives. Rates displayed by xosview. It is a 4 core Intel Core i7-7700HQ CPU chip yielding 8 scheduled cpus. The distribution of tasks appears to be uniform.

The first major problem I encountered was with both wlan and hard wired Ethernet. I mentioned previously that I had resorted to USB wlan devices to get started. They appeared very slow. Hence there could be a USB system problem, more discussion to follow. I solved the wlan problem by removing the Qualcomm Atheros QCA6174 card and replacing it with an Intel 8260 IEEE 802.11ac - Wi-Fi Adapter, $24.63 from Amazon. The Qualcomm Atheros Killer E2500 Gigabit Ethernet Controller is not fully supported with kernels up to 4.4.140. There is a "fix" shown on the net where you 1)sudo modprobe alx and then 2)echo 1969 e0b1 | sudo tee /sys/bus/pci/drivers/alx/new_id. I currently do not know what this does. I have used this fix to transfer data, but do not know what happens when Yast2 Network Settings is executed. I am hoping that newer kernels might fix this correctly.

Second major problem was getting the external HDMI port to operate. I have been trying to use the Nouveau open source driver rather than the proprietary Nvida driver. I am just starting on this. The authors of the Nouveau driver stated that a later version of the kernel was required for Nouveau support. The graphics device shows as two cards, 1) Intel Device 591b and 2)NVIDIA GP106M [GeForce GTX 1060 Mobile.] Currently I believe only the Intel hardware is being employed.

I have suspicions about the USB hardware. As I mentioned before in this thread, when it was suggested that I build a virgin Leap 15 system, the Leap 15 installation DVD hangs on the line where it says evaluating USB devices. I tried nomodset as was previously suggested and saw no change. The wlan adapter appeared to run slower than I had anticipated, but I have not measured the actual rates. It is certainly much slower than the internal Intel 8260. And in attempts to get the Nouveau graphics to load, I have had many problems with later Kernel revisions. This problem is under investigation.

I will examine the suggested commands, but most are familiar, and as I recall do not measure the quality if an implementation, such as USB. There is probably software that exercises different system components yielding some sort of quality metric. Don't know any and havent looked.

Thanks for the suggestions,
Don

--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >
This Thread