Mailinglist Archive: opensuse (1108 mails)

< Previous Next >
Re: [opensuse] kernel versions
On 08/09/2018 07:22 PM, Anton Aylward wrote:
On 2018-08-09 9:51 p.m., don fisher wrote:

The package is shown by zypper se -s 'kernel*',
kernel-default-base-4.17.13-2.1.g9079348, that I installed using zypper:

That invocation of the search function only tells you what the repositories know
You need
zypper se -i 'kernel*'
to interrogate the RPM database to see what you actually have installed.

Then, knowing that, you can run 'rpm -ql <package_name>'
to see what files the RPM database thinks should exist.

Then you can do a step and repeat to see if they actually exist

Actually you might do it in a simpler fashion; go directly to the RPM database
and query that:
rpm -qa| grep 'kernel*'

using that I get


I then step and repeat, for example running:
rpm -ql kernel-default-4.17.13-2.1.g9079348 | xargs ls -l
and see that there are no errors.

zypper dist-upgrade --from kernel-std-repo. I think it has nothing to do with
me deleting files in other directories.

No, just what did you delete then?

I tried to start over, but as described in another email, the damn Leap 15
DVD install program would not boot. The Leap 42.3 DVD boots without any
problems. This can have absolutely nothing to do with my installed system.

Given that your DVD has no errors ((when you downloaded the ISO did you do the
MD5 check?) (when you burnt it did you do an integrity and md5 check?))
then it sounds like you have either a reader tolerance problem or a BIOS
problem. In my time I've seen both.

I've also seen situations where re-burning the DVD worked, where re-downloading
and re-burning the DVD worked. Laser readers are better than floppy drives as
far as tolerance go, but there are still many cases ...

(I'm assuming that both disks ARE DVD and you are using a DVD reader. Some
disks do fit on a CD, such as the "LiveCD' versions or the Net Install

The only files I deleted were in /boot/ and the /lib/modules that were specific to the kernel.


To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
Follow Ups