Mailinglist Archive: opensuse (1108 mails)

< Previous Next >
Re: [opensuse] kernel versions
On 08/08/2018 09:09 PM, Anton Aylward wrote:
ALERT! ALERT! DANGER WIL ROBERTSON!

On 08/08/18 09:57 PM, don fisher wrote:


I have tried to perform research on the desired actions, and I have asked
many questions on this list. Also, the way I have removed the unwanted
kernel upgrades was to grep on my entire system for any files containing the
version number of the undesired installed kernel. Then I deleted all of these
files and reran grub2-mkconfig.

Nononono
Don't do it that way.
You end up with an inconsistent system and indeterminate results an.

Do it all with zypper.

1. add the repository
2. install using zypper.
let zypper take care of consistency and
rebuilding grub in a consistent manner
3. remove things using zypper



This part all appears to work, except for the appearance of the deleted
kernels in the Yast2 GUI candidates window.

that's an inadequate statement.
By definition, yast will show you everything available.
So what?
It is what it has marked as install or not that matters.

And if you've screwed around by deleting files manually it means your RPM
database, which is what zypper and yast (and the underlying libraries they have
in common) base their knowledge one, no longer matches what you have installed.
That translates to:

YOU'VE SCREWED UP YOUR SYSTEM

In the meantime, try to limit or repair it by running 'zypper verify'


I downloaded these kernels from the page:

https://software.opensuse.org/package/kernel-default,

Nononono.

You add that to your repositories (using 'zypper addrepo' (try 'zypper help
addrepo' for details))

You then use 'zypper in --from' specifying that repository (use 'zypper help in'
for details).

DO NOT UNDER ANY CIRCUMSTANCES TRY ADDING OR DELETING FILES DIRECTLY
YOU WILL MAKE YOUR SYSTEM INCONSISTENT

... or worse, and may not be able to recover from the damage you've caused by
your manual intervention.


under the "Opensuse 42.3", "show community packages". It shows "1 click
install" for the suggested kernels. This method of installing desired
software has been suggested many times on this list. What is different here?

Using the web based search is great for finding things that you can't find
because they are not in a Well Known Repository.
THAT IS NOT THE CASE HERE

What is different is that you are not following a tried and trued method and
because you didn't do that you are not trying a shotgun approach.

The web search is a superb tool but we are dealing with a Well Known Repository
and one that has been discussed and recommended very often on this list.


I am trying to learn more, but have found that sometimes experimentation is
all that works. I have read the entire zipper man page, but still do not
understand how all the parts fit together.

Zypper does everything that Yast in sw-single mode does and bit more, They are
both front ends for the relevant libraries. GUIs are a bit more 'idiot stick'
since they have all the icons. Both are 'Swiss army knives' with lots of
blades.

When you run 'zypper help' it gives you all the possible first order commands.

I always use zypper; but then I don't use about 85% of the possible commands.
And of the 15% I do use, about 3% I have to look at the 'help' 'cos I don't use
them often enough to remember the syntax.

But the circumstances I use yast are very very very very very rare.
Compared to zypper it is too slow, to unresponsive, to much fiddle-faddle in the
way of getting Things Done.
In Yast those map to various icons.

The last time I was required to build kernels they were first downloaded from
kernel.org, configured and then compiled.

Gee, I don't thing I've done that since the beginning of the 1990s with
Slackware. Too much aggravation. It turned me off Linux and I went back to
using SCO.


I have been trying to learn how to do things the Opensuse way.

Manually deleting files so as to upset the consistency of the RPM database is
certainly NOT the OpenSUSE way!

=====================================================

At this point, I think that I and Patrick might like to know just what
repositories you DO have configured.

So, can you please show us the output of running, as root, 'zypper lr'

With your notes, and the opensuse ref manual section "Installing/Removing Multiple Kernel Versions with Zypper" I thought I had made progress, but reboot was still a problem.

I still find broken links in the directory /lib/modules/4.17.13-2.g9079348-default/weak-updates/updates/drivers/net/wireless/realtek/rtl8xxxu. I have one of these devices.

zypper se -si 'kernel*' showed nothing strange. sudo zypper refresh executed without errors.

As requested, the output of zypper repos is, showint the addition of my kernel-std-repo:
A list of my repositories is:
# | Alias | Name | Enabled | GPG Check | Refresh
---+-------------------------------------+-----------------------------------------+---------+-----------+--------
1 | download.opensuse.org-non-oss | Main Repository (NON-OSS) | Yes | (r ) Yes | Yes
2 | download.opensuse.org-non-oss_1 | Update Repository (Non-Oss) | Yes | (r ) Yes | Yes
3 | download.opensuse.org-oss | Main Repository (OSS) | Yes | (r ) Yes | Yes
4 | download.opensuse.org-oss_1 | Main Update Repository | Yes | (r ) Yes | Yes
5 | http-download.opensuse.org-07b77dbf | home:nuklly | Yes | (r ) Yes | Yes
6 | http-download.opensuse.org-121621ad | home:so_it_team | Yes | (r ) Yes | Yes
7 | http-download.opensuse.org-56bf35aa | home:Ximi1970:openSUSE:Extra | Yes | (r ) Yes | Yes
8 | http-download.opensuse.org-5dbaf090 | home:winski | Yes | (r ) Yes | Yes
9 | http-download.opensuse.org-68d87445 | devel:languages:perl:CPAN-G | Yes | (r ) Yes | Yes
10 | http-download.opensuse.org-6fae2c22 | X11:windowmanagers | Yes | (r ) Yes | Yes
11 | http-download.opensuse.org-9721b024 | openSUSE:Leap:42.3:Update | Yes | (r ) Yes | Yes
12 | kernel-std-repo | kernel-std-repo | Yes | (r ) Yes | No
13 | openSUSE-Leap-42.3-0 | openSUSE-Leap-42.3-0 | No | ---- | ----
14 | repo-debug | openSUSE-Leap-42.3-Debug | No | ---- | ----
15 | repo-debug-non-oss | openSUSE-Leap-42.3-Debug-Non-Oss | No | ---- | ----
16 | repo-debug-update | openSUSE-Leap-42.3-Update-Debug | No | ---- | ----
17 | repo-debug-update-non-oss | openSUSE-Leap-42.3-Update-Debug-Non-Oss | No | ---- | ----
18 | repo-source | openSUSE-Leap-42.3-Source | No | ---- | ----
19 | repo-source-non-oss | openSUSE-Leap-42.3-Source-Non-Oss | No | ---- | ----

Don





--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >
This Thread