Mailinglist Archive: opensuse (1352 mails)

< Previous Next >
Re: [opensuse] Adobe Reader no longer works - 15.0
On 06/28/2018 04:18 AM, Carlos E. R. wrote:
On 2018-06-28 01:13, Doug wrote:

On 06/27/2018 06:26 PM, don fisher wrote:
On 06/04/2018 05:44 PM, James Knott wrote:
Since installing Leap 15.0, I now see Adobe Reader no longer works.

Has anybody made any progress since this thread was initiated? I
looked ant the binary that is finally loaded and found:

/usr/lib/Adobe/Reader9/Reader/intellinux/bin/acroread: ELF 32-bit LSB
executable, Intel 80386, version 1 (SYSV), dynamically linked,
interpreter /lib/ld-linux.so.2, for GNU/Linux 2.2.5, stripped

Is there something in Leap 15 that prevents is from executing ELF
32-bit LSB executables? If so, what is it and can it be worked around.
I ran Yast2 and I think I installed all of the 32 bit libs. I have
seen acroread offered on the opensuse packages list, and other places.
The site says it builds, but gives no info I saw on execution.

For better or worse, Adobe Reader is obsolete. Have you looked at
getting Master PDF Editor 5? It's pretty complete, AFAIK.

Again, stop that bullshit. There are features that NO free Linux pdf
viewer has. Namely: cryptographic signature checking, and javascript
support in forms.

There are some alternative commercial PDF viewers that have some of it:

<https://www.qoppa.com/pdfstudioviewer/>
Apparently has forms support.
Has signature checking.

Foxit for Linux
Apparently has forms support.
No signature checking.

I tried adding the above 2 libraries and acroread appears to work for me. And it exits fine, but I use the FVWM2 window manger which may be different.
How does /usr/lib/Adobe/Reader9/Reader/intellinux/lib get included in your LD_LIBRARY_PATH search path. I added it manually to mine, but other emails appear to imply it was added automatically, like I assume it should be.
I was considering trying to find the above two libraries in debug or source form and determine with gdb what the problem is. Then possibly file a bug report. Is this a worthwhile effort?

Thanks for all the assistance!
Don


--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups