Mailinglist Archive: opensuse (1352 mails)

< Previous Next >
Re: [opensuse] Adobe Reader no longer works - 15.0
On 06/27/2018 05:11 PM, Simon Lees wrote:


On 28/06/18 07:56, don fisher wrote:
On 06/04/2018 05:44 PM, James Knott wrote:
Since installing Leap 15.0, I now see Adobe Reader no longer works.

Has anybody made any progress since this thread was initiated? I looked
ant the binary that is finally loaded and found:

/usr/lib/Adobe/Reader9/Reader/intellinux/bin/acroread: ELF 32-bit LSB
executable, Intel 80386, version 1 (SYSV), dynamically linked,
interpreter /lib/ld-linux.so.2, for GNU/Linux 2.2.5, stripped

Is there something in Leap 15 that prevents is from executing ELF 32-bit
LSB executables? If so, what is it and can it be worked around. I ran
Yast2 and I think I installed all of the 32 bit libs. I have seen
acroread offered on the opensuse packages list, and other places. The
site says it builds, but gives no info I saw on execution.

What broke?
Don


That still doesn't really tell us anything we don't already know, if you
try "ldd /usr/lib/Adobe/Reader9/Reader/intellinux/bin/acroread" you will
see a list of all the libraries it requires, my guess is that atleast
one of the core libraries it lists is now at a different incompatible
version in Leap 15, if someone had access to the source code fixing it
might be as simple as recompiling it, or it may require some more
complex alterations but we will never know as we can't access the source
code.

Please help with ldd. I generated an output from both my 42.3 system and Leap 15 system. I can attach them if you wish. I compared them and they are not the same, 81 libs in 42.3 vs 72 libs in Leap 15. But all the files searched for are found except for about 10 at the beginning of 42.3 and 15 that show file not found. But these files are all located in the adobe directory /usr/lib/Adobe/Reader9/Reader/intellinux/lib. I do not understand how acroread can be built and not have links to its own directories. Do I need to adjust my library search paths? I added the above to my LD_LIBRARY_PATH and now all libraries are found in the ldd dump.

The executable built on the Leap 15 system executes on the 42.3. The executable built for the 42.3 system does not execute on the Leap 15 system.

I tried, and achieved the same results, loading the 42.3 distribution on the 15 system.

I have tried all the things I can muster without trying to get into the binary and see where it is failing.

Any ideas?
Don

--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups