Mailinglist Archive: opensuse (1352 mails)

< Previous Next >
Re: [opensuse] Adobe Reader no longer works - 15.0


On 28/06/18 07:56, don fisher wrote:
On 06/04/2018 05:44 PM, James Knott wrote:
Since installing Leap 15.0, I now see Adobe Reader no longer works.

Has anybody made any progress since this thread was initiated? I looked
ant the binary that is finally loaded and found:

/usr/lib/Adobe/Reader9/Reader/intellinux/bin/acroread: ELF 32-bit LSB
executable, Intel 80386, version 1 (SYSV), dynamically linked,
interpreter /lib/ld-linux.so.2, for GNU/Linux 2.2.5, stripped

Is there something in Leap 15 that prevents is from executing ELF 32-bit
LSB executables? If so, what is it and can it be worked around. I ran
Yast2 and I think I installed all of the 32 bit libs. I have seen
acroread offered on the opensuse packages list, and other places. The
site says it builds, but gives no info I saw on execution.

What broke?
Don


That still doesn't really tell us anything we don't already know, if you
try "ldd /usr/lib/Adobe/Reader9/Reader/intellinux/bin/acroread" you will
see a list of all the libraries it requires, my guess is that atleast
one of the core libraries it lists is now at a different incompatible
version in Leap 15, if someone had access to the source code fixing it
might be as simple as recompiling it, or it may require some more
complex alterations but we will never know as we can't access the source
code.

--

Simon Lees (Simotek) http://simotek.net

Emergency Update Team keybase.io/simotek
SUSE Linux Adelaide Australia, UTC+10:30
GPG Fingerprint: 5B87 DB9D 88DC F606 E489 CEC5 0922 C246 02F0 014B

< Previous Next >
Follow Ups
References