Mailinglist Archive: opensuse (1355 mails)

< Previous Next >
[opensuse] Cups compatibility
  • From: Ansgar Esztermann-Kirchner <aeszter@xxxxxxxxxxxxx>
  • Date: Mon, 25 Jun 2018 14:42:16 +0200
  • Message-id: <20180625124216.lmrj4va4sn3o4hov@aeszter.mpibpc.intern>
Hello List,

having recently upgraded by 42.3 machine to Leap 15, I've noticed my
cups client does not talk to the (ancient) server anymore.

When I look at other machines, cups seems to have changed from 1.7.5
to 2.2.7, so maybe something changed so drastically that compatibility
is impaired?

My cups knowledge is sketchy, so I do not really know how to debug
this problem. Any hints?

For what it's worth, I see
E [25/Jun/2018:14:23:45 +0200] cupsdReadClient: 20 IPP Read Error!
in the server's error_log

while the client reports
lpr: bad request

My /etc/cups/client.conf is unchanged from previous versions (i.e.
it's still working for Leap 42.3 and earlier):
ServerName our_cups_server.mpibpc.intern/version=1.1

Thanks,

A.
--
Ansgar Esztermann
Sysadmin
http://www.mpibpc.mpg.de/grubmueller/esztermann
< Previous Next >