Mailinglist Archive: opensuse (1355 mails)

< Previous Next >
[opensuse] Baffled by shell script
A script that has worked for many generations of openSuSE fails under the LEAP 15 installation. The script ('ted') is located under /usr/local/bin. It reads:

#!/bin/sh
# Script for EDT look-alike ED v1.5.9

eddsk=/usr/local/ED-159

$eddsk/edc $eddsk/vt200.ed $eddsk/ed.setup 0 0 -1 -u $1 $2 $3 $4 $5 $6 $7


It is used for text editing. A command such as: 'ted filename' gives the error message

/usr/local/bin/ted: line 7: /usr/local/ED-159/edc: No such file or directory


But the file exists. The command 'dir /usr/local/ED-159/edc' yields
-rwxr-xr-x 1 root root 214104 Sep 10 2006 /usr/local/ED-159/edc

The directory chain and permissions are as they need to be.

I have tried numerous variations and tests, but must be missing the one that will work. Yes, the code and script are pretty ancient. Was there some peculiar change to the shell (bash) code?

Thanks
Joe

--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >