Mailinglist Archive: opensuse (1355 mails)

< Previous Next >
Re: [opensuse] yast2 over ssh
22.06.2018 20:15, Carlos E. R. пишет:
On 2018-06-22 12:04, Simon Becherer wrote:
Hi carlos,


I can't test this just now, but two suggestions:


1) ssh -X root@machine

which is what I normally do.

2) ssh -X user@machine su -


first one i could not test, i have some restrictions set
(i do not know where) to do not ssh direct as root.

second one do exactly same as without "user@"

i tried:

yast2 --gtk
.. the gtk gui has beeen retired, fallung back to qt
empty not responding window

yast2 --qt same here empty not respons window

yast2 --ncurses will start

Finally I managed to update my test TW system, and I can reproduce the issue.

I did "ssh -X root@machine" from 42.3 XFCE to TW. Then I started "yast -qt"
and got an empty window that did not respond, I have to forcibly close it.


Tumbleweed:~ # yast --qt
libGL error: failed to load driver: swrast
No XVisualInfo for format QSurfaceFormat(version 2.0, options
QFlags<QSurfaceFormat::FormatOption>(), depthBufferSize -1, redBufferSize 1,
greenBufferSize 1, blueBufferSize 1, alphaBufferSize -1, stencilBufferSize
-1, samples -1, swapBehavior QSurfaceFormat::SwapBehavior(SingleBuffer),
swapInterval 1, colorSpace QSurfaceFormat::ColorSpace(DefaultColorSpace),
profile QSurfaceFormat::OpenGLContextProfile(NoProfile))
Falling back to using screens root_visual.
QXcbShmImage: xcb_shm_create_segment() failed for size 1420440

https://lists.opensuse.org/opensuse-factory/2018-06/msg00078.html

Looks more like finger pointing to me (i.e. - it worked in the past in
Qt, then stopped, then Qt claim it is Xserver fault. Go figure).

Anyway, ssh is obviously not the only way to forward sockets from remote
to local system, so patch to Xserver which checks for process name looks
ridiculous.

The X11 connection broke (error 1). Did the X11 server die?
Tumbleweed:~ #



< Previous Next >