Mailinglist Archive: opensuse (1355 mails)

< Previous Next >
Re: [opensuse] Problem with system suddenly swapping with large amount of ram (seems a memory leak?)
In data martedì 12 giugno 2018 23:22:25 CEST, Patrick Shanahan ha scritto:
Hallo Patrick

* stakanov <stakanov@xxxxxxxxxx> [06-12-18 16:21]:
[...]

I tried with akonadictl restart, or with akonadictl stop
I have narrowed down the problem to:
a) akonadi, that grows in size after time goes by (thus it seems to have a
leak?)

move and rebuild the akonadi database. it may be a squirrelly entry.

Sorry in what sense? Move to a new user account? I found the filters being
probably the major problem. Currently I substitute them one by one setting up
a copy and deleting the old ones. Seems to work to some extend.
b) qtwebkit. Whenever the system behaves oddly then I found a zombi
process of qtwebkit for mercurio, and about 10 instances of qt webkit
running.
don't know what mecurio is but, replace or disable it until other problems
are solved. then run it with debug or trace.
Mercurio is my user id that runs all the pop mail tasks (that is physically
separated from e.g. entropia where I do surf and mailing list. Rational is to
avoid to a max having that user compromised as it manages e.g. online shopping
tasks (payments) and private mail. I am ultra extremely compartimental when
setting up my systems. Makes life also more ordered.
The problem appears to be related with powersaving here too. Once the system
is idle for a long time, something crashes or leaks. Sometimes the memory gets
huge or... the temp goes up until emergency shutdown. In top in these cases
you see often zombies of qt webkit.
I found out also the following: when the ram is high, shutdown of kmail/
kontact does not make it better.
But akonadictl stop makes it a bit better. When doing "exit kontact, then
doing akonadictl and then (and here we go) you start kontact again, this will
segfault silently. The start of kontact right hereafter will succeed instead
and the memory will be normal again...
If you can give me some hints about how to catch what is happening, would be
great for a report because I can reproduce this quite easily (it is sufficient
to let the system idle long enough.

c) when this happens (also without suspend to disc, it is sufficient to
have the system idle for some time) you have the wlan that ceases to
work. Oddly it says it is active and working but network does not seem to
resolve addresses. I will try now the work around to define a 8.8.8.8 as
obligatory dns in nw- manager. Maybe this can help with the last point.
Currently I am not positively impressed with the quality of this release,
I am honest.
If asked i would advice to stay with 42.3 currently as long as possible.

what are your network settings?
Well this bug is unrelated to kontact or, related in the sense that it is
triggered by suspend to disk and especially when the system is running but is
idle for a long time (e.g. 2 - 3 hours.
That is the point, they are very very standard. Today I had incoming updates
to pam, will see if this makes a difference. It appears that there is a
permission problem? together with a wake up problem and in the latter aspect
especially it seems that the wlan cannot access the kwallet when waking up. I
am still trying to understand, but it goes in that direction. So it could also
be a race condition, that e.g. kwallet wakes up too late for wlan that tries
already to reconnect.
A part of this, firewall is very restrictive (literally nothing allowed but
surfing and mail) and ipv6 is set to ignore. But ipv4 vs 6 should make no
difference as when you start the network works well and connects (with that
strange ritual that first it asks for password root, then it says "no secrets
where given" and "deactivated wlan" then it asks again(!) the root password,
then wallet comes up and then ..... it connects. But it does so also if you
just press enter or give a wrong root password. Now I filed a bug time ago for
42.3 on this behalf and did take it to 15 only yesterday, describing the
problem. Let us see if somebody finds the time to respond.
If not: dns is set to be taken from the router (which has a double entry, if
one would fail. Resolve.conf appears normal and does not complain.
In journalctl I found something about complaining "empty window for wallet" so
I think there is the problem.
In the meanwhile, thank you for asking.




_________________________________________________________________
________________________________________________________
Ihre E-Mail-Postfächer sicher & zentral an einem Ort. Jetzt wechseln und alte
E-Mail-Adresse mitnehmen! https://www.eclipso.de



--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >