Mailinglist Archive: opensuse (1355 mails)

< Previous Next >
Re: [opensuse] 'mailto' + 'postfix' at local machine, host or domain name not found
  • From: Per Jessen <per@xxxxxxxxxxxx>
  • Date: Thu, 07 Jun 2018 08:21:10 +0200
  • Message-id: <pfaism$hqv$2@saturn.local.net>
Simon Becherer wrote:

Hi per,


i changed:

mydestination = $myhostname, localhost.$mydomain, localhost,
$myhostname.$mydomain, $myhostname.site myhostname = becherer1

so i got the old behavior back. :-)) (but this 2 lines are different
from old setup, so there must be another way in the old system to do
this.)

Hi Simon, I'm glad you got it to work.

what i do still not understand is why did $myhostname.$mydomain
not the job because "site" is in yast as domainname set.
so the result should be "becherer1.site" (i have no idear how to check
what is inside mydomain)

The default is $myhostname, without the first component. For
$myhostname, the default is 'hostname -f'.

inside this configuration file (main.cf) i do
not see where mydomain is set, so i was guessing its something global.

It has a default value - 'postconf -d' will show you.

i have taken also a look inside the manpages, but also not found if i
have to set it or if it is already set somewhere.

If you look in main.cf, there is quite a bit of explanation in the
comments.



--
Per Jessen, Zürich (17.8°C)
http://www.hostsuisse.com/ - virtual servers, made in Switzerland.


--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups
References