Mailinglist Archive: opensuse (1355 mails)

< Previous Next >
Re: [opensuse] Documentation on using an alternate display manager like xdm or fvwm
On 06/05/2018 01:40 PM, don fisher wrote:
On 06/04/2018 08:33 PM, don fisher wrote:
The released notes says the setting up the use of an alternate display manager has mover from /etc/sysconfig to the alternatives system. I can't locate documentation on that.

The release notes says to use update-alternatives to Set Login Manager and Desktop Session. That is only thing I see in the release notes. I do not know what "To enable graphical management of alternatives, use the YaST module Alternatives" is going to do, and to what files. There is an example there used to switch the default-displaymanager to xdm:

sudo update-alternatives --set default-displaymanager \

Login manager: default-displaymanager

I have used fvwm2 in the past and would like to use it again. I tried to enable fvwm in the startup window present after booting, before logging on, but nothing worked. I am just looking for documentation now. My current Leap 15 system is pretty lame, so the docs may be in /usr/share, which I am currently not able to confirm.


I have made some progress. Now sure what is real and what is coincidence. I removed the start fvwm line out of my .xinitrc file. After selecting fvwm at the boot screen the system started, and I executed .fvwm it the window I generated in my .Xinitrc file. Another window is presented, but if I close it I am logged out. Who or what generates this window? It appears to come before the .xinitrc in my home directory.

I am also having trouble with Xresources. It appears from the operation of some windows that options in the .Xresources file are recognized. But when I do a sudo xrdb -merge ~/.Xresources, no errors are reported but nothing changes. If I execute listres -all a host of resources are liste, but none of those in my .Xresources are present. I have settings for emacs and xosview, and if I search the listed resources none of these names appear. Please offer suggestion on how to get the resources on xosview to exist.

I am used to going from the startx command into my home page and executing the .xinitrc. What happens now after I enter my password at the console window and my windows are presented?


Made a little more progress. If I execute "appres xosview" a list of the attributes in my .Xresources file is presented. But when I launch xosview it still does not appear to load these resources. I looked at the "" and found a Leap 15 viable version. It says it is "A small program which is mostly configurable using resources via ~/.Xresources", where mine are. A bit confused.


To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >