Mailinglist Archive: opensuse (1352 mails)

< Previous Next >
Re: [opensuse] Problem with leap 15 upgrade
01.06.2018 00:37, David Haller пишет:
Hello,

On Thu, 31 May 2018, Andrei Borzenkov wrote:
31.05.2018 10:18, David Haller ?????:
On Wed, 30 May 2018, don fisher wrote:
[..]
When I upgraded to leap 14 I received a lot of problems because my disk, a
Samsung 1TB SSD was not recognized.
Details: Unknown udev device
/dev/disk/by-id/scsi-1ATA_Samsung_SSD_840_EVO_1TB_SiD9NSAFB28745F-part2
^ That should probably be a 'S'

No, this is really "1", it denotes NAA type for device identification
that is used to build by-id path.

And what would "NAA" be?

You ask "what NAA means" or you ask "what type is in this case"?


I just got

And your distribution and version is ... ?


ata-<VENDOR>_<MODEL>_<SERIAL>[-part*]
scsi-SATA_<VENDOR>_<MODEL>_<SERIAL>[-part*] and

So what? The rules that are installed on your system create this name
for your specific devices. That does not mean that same must now happen
on every other system out there.

It is quite possible that rules have changed and cause problem on
update, which would mean regression.

This specific link should be created by
61-persistent-storage-compat.rules. File has changed between Leap 42 and
Leap 15. If someone has system with both Leap 42 and Leap 15 and can
demonstrate that Leap 15 no more creates this link, this should be
reported as a bug (regression).

wwn_<WWN_ID>[-part*]

in /dev/disk/by-id. Ok, I've no SAS disks. But the 840 series?
And there's nothing in the kernel (4.16.x) either.

-dnh



--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >