Mailinglist Archive: opensuse (795 mails)

< Previous Next >
Re: [opensuse] Again, trying to find a suitable video editor: VidCutter v5
  • From: "Carlos E. R." <robin.listas@xxxxxxxxxxxxxx>
  • Date: Thu, 30 Nov 2017 16:34:38 +0100 (CET)
  • Message-id: <alpine.LSU.2.21.1711301625250.31979@Telcontar.valinor>
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1



On Thursday, 2017-11-30 at 15:06 -0000, Peter Suetterlin wrote:
Carlos E. R. wrote:

I tried with the first episode of a particular serial that was recorded
somewhat differently (not something I can do at will). This file succeeds to
load in vidcutter, I could remove lead and tail, with some problems.

The resulting video displayed no video on xine.

It played well in vlc.

But it had lost the subtitles and the second audio track (Japanesse in this
case).

If vidcutter is unable to keep the two audio tracks it is no use to me.

This is really weird.
So I just tried the big_buck_bunny.mp4, could without issues load it in
vidcutter v5, cut out a subclip and save it, and properly play the edited one
using mpv.

Then I loaded an mkv, a 27GB Bluray rip with 3 audio tracks and one subtitle
track. Again marked a small piece of it, saved it. The edit had all three
audio and the subtitle tracks intact....

Weird.


There are other difficulties: I can move with the cursor keys, but the "left
cursor" key works only for a bit, then it gets stuck. I have to use the
mouse to pass that point, and the mouse is very innacurate, too sensitive.

Going backwards is always an issue, because of the differential and reference
frames. Especially on not too powerfull hardware. I think you have to go
back to last I-frame and then apply diff frames up to the previous frame.

Ah. Well, the code could go find that I-frame automatically. Other programs do not have that issue.

I tried that (back move) with my laptop, and did not have stop issues, except
it being quite slow (2-3fps). (lappy is quite beefy though, i7 with 16GB)

Hovering with the mouse over the buttons produce a grey text box with
probably a hint, but the text is missing.

I noticed that there is a hint at the status line at the bottom. But I do get a grey box a bit below and to the right of the button.

Hu - I don't get boxes, the info is displayed in the bottom line of the
window... What does Menu->about vidcutter tell? Mine has

libmpv: 0.27.0 FFmpeg: 3.4
Python: 3.6.3 PyQt5: 5.9 SIP: 4.19.3

(This is a Tumbleweed machine)

Well, different, this is leap 42.2.


libmpv: 0.25.0 FFmpeg: 3.3.4
Python: 3.4.6 PyQt5: 5.5.1 SIP: 4.16.9
Copyright © 2017 Pete Alexandrou
Website: https://vidcutter.ozmartians.com
Found a bug? You can REPORT IT HERE.


Well, obviously I have to report upstream, as the issues seem to be related to the video files I have.


Is there a mail list? The "report it here" is github. :-?


- -- Cheers,
Carlos E. R.
(from openSUSE 42.2 x86_64 "Malachite" at Telcontar)

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2

iEYEARECAAYFAlogJQ4ACgkQtTMYHG2NR9X37QCgmKdBZR2x3v6OpIGKGnu0sLYU
MaMAnjUHU5FEq8cSCgJiZBCRp+RrysgF
=xyvp
-----END PGP SIGNATURE-----
< Previous Next >