Mailinglist Archive: opensuse (794 mails)

< Previous Next >
[opensuse] Display problems
  • From: Larry Stotler <larrystotler@xxxxxxxxx>
  • Date: Wed, 29 Nov 2017 20:23:37 -0500
  • Message-id: <CADwjxuTu6i7X5PYtaiAWCw=gprKYv+hgmVdq7WWxDRU9J6bgzg@mail.gmail.com>
I'm running Leap 42.3 on a Dell Precision m6400 laptop. Core2 Quad
Q9000, 8GB RAM, ATI Firepro m7740(RV740/M97 GL)

The laptop has a DisplayPort on it and I have a dock that has the
Displayport & a Dual-Link DVI connector.

I have an HP ZR2740w that has a native resolution of 2560x1440 (or
1440p). This monitor doesn't have an onscreen display, but it has
Display Port & Dual Link DVI connectors.

This is a fresh install.

When I connect with the DisplayPort cable, it is detected on the
laptop & the dock but I get nothing on the screen. The system
recognizes it(X & using xrandr) is there but no matter what resolution
I try I get nothing. The light on the display shows it's asleep(solid
orange).

When I connect with a Dual Link DVI cable to the dock(which supports a
max res of 2560x1600), it only allows 1440x900 or 1280x720, and will
only work at 1280x720. When I try to use 1440x900 the light on the
display just blinks blue.

The Firepro card has 1GB RAM, so it's got plenty for the 27" LCD and
the onboard 1440x900 LVDS.

I also tried it with my Thinkpad T60p(firegl 5200 with 512MB) with the
dock's DVI connector and it only works at 1440x900.

I had Windows 7 on the Dell before and it only worked at 1440x900.
The laptop would lock up when playing video(which seems to be a common
problem under windows with this card).

I'm using the stock ATI driver. I didn't see a proprietary driver to install.

I'm at my wits end. Any suggestions?

--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups