Mailinglist Archive: opensuse (795 mails)

< Previous Next >
Re: [opensuse] Again, trying to find a suitable video editor: VidCutter v5
  • From: "Carlos E. R." <robin.listas@xxxxxxxxxxxxxx>
  • Date: Wed, 29 Nov 2017 23:40:23 +0100 (CET)
  • Message-id: <alpine.LSU.2.21.1711292335190.31979@Telcontar.valinor>
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1



On Wednesday, 2017-11-29 at 17:36 -0000, Dave Howorth wrote:

On Wed, 29 Nov 2017 13:45:09 +0100 (CET) "Carlos E. R." <> wrote:
On Wednesday, 2017-11-29 at 17:44 +1100, Basil Chupin wrote:
On 24/11/17 14:50, Carlos E. R. wrote:


Anyway, I installed that rpm, but vidcutter still doesn't work. I
managed to tell it to open a video file, it did nothing, the
timeline displays nothing, it does not play the video, it is
impossible to cut anything. If I give the name of the video file
on the commandline, it crashes.

It works, Carlos, it really does (Leap 42.3 + VidCutter
v5.0.0) :-).

It doesn't in 42.2, I tried again yesterday. It doesn't load the file.

It plays in 42.2 for me.

Well, I reported the issue in the packman mail list, and Luigi Baldoni is having a look. He has already solved the dependency issue, he told me, and asked to run with the --debug command line option. That produced a lot of output which I posted back there; I can not read pythonesse, so I don't know what it means ;-)

I'll post it here again in case more eyes are of help ;-)


cer@Telcontar:~/Fusion/Hacer/Trek> vidcutter --debug p.mpeg QML debugging is enabled. Only use this in a safe environment.
2017-11-29 23:27 - vidcutter.libs.mpvwidget - INFO - [cplayer] mpv 0.25.0 (C)
2000-2017 mpv/MPlayer/mplayer2 projects
2017-11-29 23:27 - vidcutter.libs.mpvwidget - INFO - [cplayer] built on May 9
2017
2017-11-29 23:27 - vidcutter.libs.mpvwidget - INFO - [cplayer] ffmpeg library
versions:
2017-11-29 23:27 - vidcutter.libs.mpvwidget - INFO - [cplayer] libavutil
55.58.100
2017-11-29 23:27 - vidcutter.libs.mpvwidget - INFO - [cplayer] libavcodec
57.89.100
2017-11-29 23:27 - vidcutter.libs.mpvwidget - INFO - [cplayer] libavformat
57.71.100
2017-11-29 23:27 - vidcutter.libs.mpvwidget - INFO - [cplayer] libswscale
4.6.100
2017-11-29 23:27 - vidcutter.libs.mpvwidget - INFO - [cplayer] libavfilter
6.82.100
2017-11-29 23:27 - vidcutter.libs.mpvwidget - INFO - [cplayer] libswresample
2.7.100
2017-11-29 23:27 - vidcutter.libs.mpvwidget - INFO - [cplayer] ffmpeg version:
3.3.4
2017-11-29 23:27 - vidcutter.libs.mpvwidget - INFO - [cplayer] 2017-11-29 23:27 - vidcutter.libs.mpvwidget - INFO - [cplayer] Configuration: ./waf configure --prefix=/usr --bindir=/usr/bin --mandir=/usr/share/man --libdir=/usr/lib64 --docdir=/usr/share/doc/packages/mpv --confdir=/etc/mpv --enable-cdda --enable-libmpv-shared --enable-zsh-comp --enable-manpage-build --enable-libarchive --disable-sdl1 --disable-sdl2 --disable-build-date --disable-debug
2017-11-29 23:27 - vidcutter.libs.mpvwidget - INFO - [cplayer] List of enabled
features: 52 alsa asm atomics audio-input avutil-imgcpy-uc caca cdda cplayer
cuda-hwaccel dlopen drm dvbin egl-helpers egl-x11 encoding fchmod gcc-tls gl
gl-wayland gl-x11 glibc-thread-name glob gnuc iconv is_ffmpeg jack jpeg lcms2
libarchive libass libass-osd libav libavcodec libavdevice libbluray libdl libm
libmpv-shared librt libsmbclient libv4l2 linux-fstatfs lua nanosleep optimize
oss-audio oss-audio-native plain-gl posix posix-or-mingw posix-spawn pthreads
pulse shm subprocess termios tv tv-v4l2 vaapi vaapi-egl vaapi-glx vaapi-hwaccel
vaapi-hwaccel-new vaapi-wayland vaapi-x-egl vaapi-x11 vdpau vdpau-gl-x11
vdpau-hwaccel vdpau-hwaccel-new videodev vt.h wayland x11 xv zlib zsh-comp
2017-11-29 23:27 - vidcutter.libs.mpvwidget - INFO - [global] config path: ''
-> '-'
2017-11-29 23:27 - vidcutter.libs.mpvwidget - INFO - [cplayer] Setting option
'opengl-hwdec-interop' = "auto" (flags = 64) -> 0
2017-11-29 23:27 - vidcutter.libs.mpvwidget - INFO - [opengl-cb]
GL_VERSION='3.3.0 NVIDIA 340.102'
2017-11-29 23:27 - vidcutter.libs.mpvwidget - INFO - [opengl-cb] Detected
desktop OpenGL 3.3.
2017-11-29 23:27 - vidcutter.libs.mpvwidget - INFO - [opengl-cb]
GL_VENDOR='NVIDIA Corporation'
2017-11-29 23:27 - vidcutter.libs.mpvwidget - INFO - [opengl-cb]
GL_RENDERER='GeForce 9500 GT/PCIe/SSE2'
2017-11-29 23:27 - vidcutter.libs.mpvwidget - INFO - [opengl-cb]
GL_SHADING_LANGUAGE_VERSION='3.30 NVIDIA via Cg compiler'
2017-11-29 23:27 - vidcutter.libs.mpvwidget - INFO - [opengl-cb] Loaded
extension GL_ARB_get_program_binary.
2017-11-29 23:27 - vidcutter.libs.mpvwidget - INFO - [opengl-cb] Loaded
extension GL_NV_vdpau_interop.
2017-11-29 23:27 - vidcutter.libs.mpvwidget - INFO - [opengl-cb] Loaded
extension GL_ARB_debug_output.
2017-11-29 23:27 - vidcutter.libs.mpvwidget - INFO - [opengl-cb] 16 bit texture
depth: 16.
2017-11-29 23:27 - vidcutter.libs.mpvwidget - INFO - [opengl-cb] Testing FBO
format 0x805b
2017-11-29 23:27 - vidcutter.libs.mpvwidget - INFO - [opengl-cb] Create FBO:
16x16 (16x16)
2017-11-29 23:27 - vidcutter.libs.mpvwidget - INFO - [opengl-cb] Using FBO
format 0x805b.
2017-11-29 23:27 - vidcutter.libs.mpvwidget - INFO - [opengl-cb] No advanced
processing required. Enabling dumb mode.
2017-11-29 23:27 - vidcutter.libs.mpvwidget - INFO - [opengl-cb] Loading hwdec
driver 'vaapi-egl'
2017-11-29 23:27 - vidcutter.libs.mpvwidget - INFO - [opengl-cb] Loading failed.
2017-11-29 23:27 - vidcutter.libs.mpvwidget - INFO - [opengl-cb] Loading hwdec
driver 'vaapi-glx'
2017-11-29 23:27 - vidcutter.libs.mpvwidget - INFO - [opengl-cb/vaapi-glx] Not
using this by default.
2017-11-29 23:27 - vidcutter.libs.mpvwidget - INFO - [opengl-cb] Loading failed.
2017-11-29 23:27 - vidcutter.libs.mpvwidget - INFO - [opengl-cb] Loading hwdec
driver 'vdpau-glx'
2017-11-29 23:27 - vidcutter.libs.mpvwidget - INFO - [opengl-cb] Reported
display depth: 8
2017-11-29 23:27 - vidcutter.libs.videoservice - INFO - /usr/bin/ffprobe -hide_banner -v
error -show_streams -show_format -of json
"/home_aux/cer/Fusion/Hacer/Trek/p.mpeg"
2017-11-29 23:27 - vidcutter.libs.videoservice - ERROR - Error decoding ffprobe
JSON output
Traceback (most recent call last):
File "/usr/lib64/python3.4/site-packages/vidcutter/libs/videoservice.py",
line 458, in probe
self.media = Munch.fromDict(json.loads(json_data))
File "/usr/lib64/python3.4/site-packages/simplejson/__init__.py", line 516,
in loads
return _default_decoder.decode(s)
File "/usr/lib64/python3.4/site-packages/simplejson/decoder.py", line 370, in
decode
obj, end = self.raw_decode(s)
File "/usr/lib64/python3.4/site-packages/simplejson/decoder.py", line 400, in
raw_decode
return self.scan_once(s, idx=_w(s, idx).end())
simplejson.scanner.JSONDecodeError: Expecting value: line 1 column 2 (char 1)
2017-11-29 23:27 - root - CRITICAL - File "/usr/bin/vidcutter", line 9, in
<module>
load_entry_point('vidcutter==5.0.0', 'gui_scripts', 'vidcutter')()
File "/usr/lib64/python3.4/site-packages/vidcutter/__main__.py", line 378, in
main
win = MainWindow()
File "/usr/lib64/python3.4/site-packages/vidcutter/__main__.py", line 73, in
__init__
self.file_opener(self.video)
File "/usr/lib64/python3.4/site-packages/vidcutter/__main__.py", line 89, in
file_opener
self.cutter.loadMedia(filename)
File "/usr/lib64/python3.4/site-packages/vidcutter/videocutter.py", line 798,
in loadMedia
self.videoService.setMedia(self.currentMedia)
File "/usr/lib64/python3.4/site-packages/vidcutter/libs/videoservice.py",
line 91, in setMedia
self.probe(source)
File "/usr/lib64/python3.4/site-packages/vidcutter/libs/videoservice.py",
line 458, in probe
self.media = Munch.fromDict(json.loads(json_data))
File "/usr/lib64/python3.4/site-packages/simplejson/__init__.py", line 516,
in loads
return _default_decoder.decode(s)
File "/usr/lib64/python3.4/site-packages/simplejson/decoder.py", line 370, in
decode
obj, end = self.raw_decode(s)
File "/usr/lib64/python3.4/site-packages/simplejson/decoder.py", line 400, in
raw_decode
return self.scan_once(s, idx=_w(s, idx).end())

2017-11-29 23:27 - root - CRITICAL - <class
'simplejson.scanner.JSONDecodeError'>: Expecting value: line 1 column 2 (char 1)
cer@Telcontar:~/Fusion/Hacer/Trek>



- -- Cheers,
Carlos E. R.
(from openSUSE 42.2 x86_64 "Malachite" at Telcontar)

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2

iEYEARECAAYFAlofN1cACgkQtTMYHG2NR9WNoQCcCd9mzrC5ECzbmu/GADAl1JN/
5vAAnAj+30Yu9c6xpxGPmkvKO6TzliJh
=4I3g
-----END PGP SIGNATURE-----

--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups