Mailinglist Archive: opensuse (795 mails)

< Previous Next >
Re: [opensuse] Again, trying to find a suitable video editor: VidCutter v5
On Thu, 23 Nov 2017 23:07:19 +0100 (CET)
"Carlos E. R." <robin.listas@xxxxxxxxxxxxxx> wrote:

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1



On Thursday, 2017-11-23 at 21:38 -0000, Dave Howorth wrote:
On Thu, 23 Nov 2017 20:32:01 +0100 (CET) "Carlos E. R." <> wrote:
On Tuesday, 2017-11-21 at 07:49 +0100, gumb wrote:
On 20/11/17 21:13, Carlos E. R. wrote:
On Monday, 2017-11-20 at 20:09 +0100, gumb wrote:



Version 5 is in the Packman repos now. Added yesterday.

Installing :-))

Crashes on loading:

...

FWIW, I just installed vidcutter (on 42.2) and got the same error.
'typing' is apparently a standard Python module that provides type
hints.

But ... it's apparently only standard after version 3.6.5.
So I tried:

$ python3 '/usr/bin/vidcutter'

but that gives the same error. Apparently I've only got 3.4.6

There is https://pypi.python.org/pypi/typing to download a backport
but that's further than I'm going to try.

Ah, if I enable the devel:languages:python repository then I can
install python3-typing and that fixes the error. Unfortunately, it
then says:

$ vidcutter
QML debugging is enabled. Only use this in a safe environment.
Error in sys.excepthook:

Original exception was:
Segmentation fault (core dumped)


I have the suspicion that vidcutter is written expecting a newer
version of python, so I shan't bother chasing it any further.

Thanks anyway, at least I know what is hapening. Much better than
darkness ;-)

I think I read that the move to python3 is a work in progress in TW,
so I guess that it is too early to get it into Leap 15.

Well both python 2 and python 3 are already in 42.2 so that's not a
problem, and when I just ran vidcutter directly from the command line I
saw afterwards that it automatically selected python 3 itself somehow.

I'm not a python programmer but I suppose there must be some mechanism
for a python program to declare that it needs a particular version of
the python executable to run. I'm surprised that python doesn't appear
in update-alternatives to select the default from the command line,
though I suppose it is technically unnecessary.

The work with TW may be adjusting system scripts to run properly under
python 3, ideally as well as in python 2 but perhaps at the expense of
python 2 compatibility.

Since somebody has packaged vidcutter for packman, maybe its worth bug
reporting the core dump, however that is done.

BTW, vidcutter -h runs OK, so it may be worth trying to process some
actual files. Maybe it's just the pathological case of no arguments
that causes the crash?

--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups