Mailinglist Archive: opensuse (795 mails)

< Previous Next >
Re: [opensuse] Again, trying to find a suitable video editor: VidCutter v5
  • From: "Carlos E. R." <robin.listas@xxxxxxxxxxxxxx>
  • Date: Thu, 23 Nov 2017 23:07:19 +0100 (CET)
  • Message-id: <alpine.LSU.2.21.1711232302180.24742@Telcontar.valinor>
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1



On Thursday, 2017-11-23 at 21:38 -0000, Dave Howorth wrote:
On Thu, 23 Nov 2017 20:32:01 +0100 (CET) "Carlos E. R." <> wrote:
On Tuesday, 2017-11-21 at 07:49 +0100, gumb wrote:
On 20/11/17 21:13, Carlos E. R. wrote:
On Monday, 2017-11-20 at 20:09 +0100, gumb wrote:



Version 5 is in the Packman repos now. Added yesterday.

Installing :-))

Crashes on loading:

...

FWIW, I just installed vidcutter (on 42.2) and got the same error.
'typing' is apparently a standard Python module that provides type
hints.

But ... it's apparently only standard after version 3.6.5.
So I tried:

$ python3 '/usr/bin/vidcutter'

but that gives the same error. Apparently I've only got 3.4.6

There is https://pypi.python.org/pypi/typing to download a backport
but that's further than I'm going to try.

Ah, if I enable the devel:languages:python repository then I can
install python3-typing and that fixes the error. Unfortunately, it then
says:

$ vidcutter
QML debugging is enabled. Only use this in a safe environment.
Error in sys.excepthook:

Original exception was:
Segmentation fault (core dumped)


I have the suspicion that vidcutter is written expecting a newer
version of python, so I shan't bother chasing it any further.

Thanks anyway, at least I know what is hapening. Much better than darkness ;-)

I think I read that the move to python3 is a work in progress in TW, so I guess that it is too early to get it into Leap 15.

- -- Cheers,
Carlos E. R.
(from openSUSE 42.2 x86_64 "Malachite" at Telcontar)

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2

iEYEARECAAYFAloXRpcACgkQtTMYHG2NR9XscACeOKvv75md/8HipcK7xtsBahfn
i+QAn1VnvR67//1FnCFiDiJIifczEYmk
=N/+k
-----END PGP SIGNATURE-----

--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups