Mailinglist Archive: opensuse (795 mails)

< Previous Next >
Re: [opensuse] Again, trying to find a suitable video editor: VidCutter v5
On Thu, 23 Nov 2017 21:31:27 +0000
Dave Howorth <dave@xxxxxxxxxxxxxx> wrote:

On Thu, 23 Nov 2017 20:32:01 +0100 (CET)
"Carlos E. R." <robin.listas@xxxxxxxxxxxxxx> wrote:

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1



On Tuesday, 2017-11-21 at 07:49 +0100, gumb wrote:
On 20/11/17 21:13, Carlos E. R. wrote:
On Monday, 2017-11-20 at 20:09 +0100, gumb wrote:
One for Carlos - I hope this reply goes into the right place in
this ancient thread.

I'll tell you later ;-)

I believe you were looking for video tools that would
treat/export all the original subtitle tracks. I just saw a
piece on OMG!Ubuntu! about an update to VidCutter, which *may*
- if the notes hold true - provide this functionality, but
you'll have to try it out yourself.


http://www.omgubuntu.co.uk/2017/11/vidcutter-5-0-released-improved-ui-frame-accurate-cutting



Thanks :-)

I'll try it out when it comes to packman :-)

Version 5 is in the Packman repos now. Added yesterday.

Installing :-))

Crashes on loading:

cer@Telcontar:~/Fusion/Hacer/Trek> vidcutter &
[1] 16260
cer@Telcontar:~/Fusion/Hacer/Trek> Traceback (most recent call
last): File "/usr/bin/vidcutter", line 9, in <module>
load_entry_point('vidcutter==5.0.0', 'gui_scripts',
'vidcutter')() File
"/usr/lib/python3.4/site-packages/pkg_resources/__init__.py", line
558, in load_entry_point return
get_distribution(dist).load_entry_point(group, name) File
"/usr/lib/python3.4/site-packages/pkg_resources/__init__.py", line
2682, in load_entry_point return ep.load() File
"/usr/lib/python3.4/site-packages/pkg_resources/__init__.py", line
2355, in load return self.resolve() File
"/usr/lib/python3.4/site-packages/pkg_resources/__init__.py", line
2361, in resolve module = __import__(self.module_name,
fromlist=['__name__'], level=0) File
"/usr/lib64/python3.4/site-packages/vidcutter/__main__.py", line 40,
in <module> from vidcutter.videocutter import VideoCutter File
"/usr/lib64/python3.4/site-packages/vidcutter/videocutter.py", line
30, in <module> from typing import Union ImportError: No module
named 'typing'

[1]+ Exit 1 vidcutter
cer@Telcontar:~/Fusion/Hacer/Trek>

FWIW, I just installed vidcutter (on 42.2) and got the same error.
'typing' is apparently a standard Python module that provides type
hints.

But ... it's apparently only standard after version 3.6.5.
So I tried:

$ python3 '/usr/bin/vidcutter'

but that gives the same error. Apparently I've only got 3.4.6

There is https://pypi.python.org/pypi/typing to download a backport
but that's further than I'm going to try.

Ah, if I enable the devel:languages:python repository then I can
install python3-typing and that fixes the error. Unfortunately, it then
says:

$ vidcutter
QML debugging is enabled. Only use this in a safe environment.
Error in sys.excepthook:

Original exception was:
Segmentation fault (core dumped)


I have the suspicion that vidcutter is written expecting a newer
version of python, so I shan't bother chasing it any further.

HTH, Dave

:-((


- -- Cheers,
Carlos E. R.
(from openSUSE 42.2 x86_64 "Malachite" at Telcontar)
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2

iEYEARECAAYFAloXIjEACgkQtTMYHG2NR9VvzACeJbLa6to3dUAd4knTjFm/scLl
p3kAoIjVnoR4Nrs37V3qwRTQnuteGJEK
=lLdj
-----END PGP SIGNATURE-----





--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups