Mailinglist Archive: opensuse (795 mails)

< Previous Next >
Re: [opensuse] tumbleweed and vim question
On 11/04/2017 01:10 AM, Lew Wolfgang wrote:
Hi Folks,

Okay, I'm ignorant, and my friend Google hasn't been of any help.

I installed the latest tumbleweed this afternoon and was dismayed to
see that the default vim behavior has changed.  First, searching for a
string by hitting "/" and entering the string was funky.  Then cutting
and pasting into an open vim screen in the "insert" mode using the
left and right mouse buttons did surprising things.  Pasting from the
clipboard using the "edit/paste" drop down menu worked, but that's
very cumbersome and is contrary to how I've been doing this for
35-years.

Rather than giving up and learning how to use Windows 10, is there a
way to configure tumbleweed's vim to emulate the old vi syntax?

Hmm, I got the same paste problem after a fresh TW install (with an
existing $HOME), but only in 'gnome-terminal', i.e., it worked in
'xterm'. After a reboot after 'zypper dup' from 20171030 to
20171101), now the problem seems to be gone for 'gnome-terminal'
as well ... wait - not quite.
- open gnome-terminal in regular user session (openbox here),
- sudo -i
- root$ vi /etc/hosts
- enter 'insert' mode with 'i',
- go into another terminal and double-click a word
for selection
- paste with middle mouse in root's vi session
--> pastes something completely outdated. The same happens
in xterm, so somehow the copy/paste into vim in a sudo session
is the problem - but it works perfectly with the regular user.

It also happens regardless of using 'sudo -i' or 'sudo bash' or
'su -' followed by entering vi, or also directly 'sudo vi file',
or 'su -c "vi /etc/hosts"'.
Strange and annoying ...

Have a nice day,
Berny

--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >
References