Mailinglist Archive: opensuse (783 mails)

< Previous Next >
[opensuse] ICMP Path MTU message
I just read a blog about packet fragmentation:

https://blog.cloudflare.com/ip-fragmentation-is-broken/

And then I ran the test they link to at:

http://icmpcheck.popcount.org/

The first test timed out, saying:

"The request timed out. Looks like the ICMP Path MTU message was not
delivered to you."

The second test passed, saying:

"All good! IP fragments were successfully delivered to your host."

To investigate the failure of the first test, I started tcpdump and
reran the test. The test gave the same result (good, I suppose) and
tcpdump said:

acer-suse:~ # tcpdump -ni any icmp or icmp6
tcpdump: verbose output suppressed, use -v or -vv for full protocol
decode
listening on any, link-type LINUX_SLL (Linux cooked), capture
size 262144 bytes
17:14:00.320873 IP 139.162.188.91 > 192.168.1.72: ICMP 139.162.188.91
unreachable - need to frag (mtu 905), length 136
17:14:00.332740 IP 139.162.188.91 > 192.168.1.72: ICMP 139.162.188.91
unreachable - need to frag (mtu 905), length 136
17:14:00.344596 IP 139.162.188.91 > 192.168.1.72: ICMP 139.162.188.91
unreachable - need to frag (mtu 905), length 136
^C
3 packets captured
3 packets received by filter
0 packets dropped by kernel

I'm no tcpdump expert but it looks to me that it is saying that it did
receive three ICMP Path MTU messages. Is that correct and is anybody
able to explain what's going on? (hopefully will save me hours of
RT-wrong-FM :)

TIA, Dave

PS I spent all this morning investigating why I'd lost network
connection until I discovered an intermediate network switch that my
wife had accidently turned off :( Perhaps I should have bought managed
switches!

--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >