Mailinglist Archive: opensuse (946 mails)

< Previous Next >
Re: [opensuse] rootmail does not work, no matter what [SOLVED]
  • From: stakanov <stakanov@xxxxxxxxxx>
  • Date: Thu, 28 Sep 2017 10:14:17 +0200
  • Message-id: <2857248.2HguQPT75d@roadrunner>
In data mercoledì 27 settembre 2017 16:45:02 CEST, Carlos E. R. ha scritto:
On 2017-09-27 16:30, stakanov wrote:
In data mercoledì 27 settembre 2017 14:24:44 CEST, Per Jessen ha scritto:
Per Jessen wrote:
Now let us see the difference in permissions....

entropia@roadrunner:/var/mail> cd /var/mail
entropia@roadrunner:/var/mail> dir
totale 112
-rw-r--r-- 1 connectix users 11573 27 set 11.34 connectix
-rw-r--r-- 1 mercurio users 0 27 lug 21.27 entropia
-rw-rwx---+ 1 root root 97541 23 set 00.57 root
-rw-rw---- 1 tss mail 0 10 set 09.41 tss

WTF, both users have same permissions. And why does entropia not
receive mail but connectix..does. And root doesn't????? And why doe I
have user tss?? What is user tss, I googled and did not find any
answer. Still more puzzled.

entropia does not receive any mail because the 'entropia' directory is
owned by another user 'mercurio'.
connectix does receive any mail because the 'connectix' directory is
owned by 'connectix'.

s/directory/mailbox file/

now we are nearly done. I am getting all the mail delivered to entropia.
But.... I do see in kmail only the last one. The others aren't displayed.
Why this? When I do:
s/directory/mailbox file/

What? You actually run "s/directory/mailbox file/"? How?

It shows all the mails for entropia are there.

Just login or "su -" to entropia, and use the command "mail" to see the
mail.

So, what was this all about.
a) I deactivated ipv6
b) after activating it again, Per Jessen correctly stated that one of the
users had the wrong owner. That made me understand how all began when I did
reinstall the system last time. As I had multiple system crashes (the culprit
was kmail) I had to find out if the fact of having them was kmail or the fact
of having a compromised userspace or a compromised index.
So I did archive the whole male, did migrate the user to a new userland. When
I was done I did notice that the usernumber was not the one which I wanted and
was used to for that user. So I did change it to the (in the meanwhile freed
up number) and that via yast (done in a third user while the original was shut
down) seems not to have worked as expected as for ownership of the rootmail
folder. Seems that before, mercurio had the user number of entropy.
You may educate me shortly what the usernumer is good for in the first place,
but I think I got an idea with all that.
So last question (as today I received rootmail from seccheck again) is: what
is the right, orthodox way to change the user number of a user in opensuse
without running in these troubles.
Thank you for all who helped me in this, expecially Per and Carlos but also
Freek de Kruif who gave me valuable hints for understanding. Kudos.



--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >