Mailinglist Archive: opensuse (946 mails)

< Previous Next >
Re: [opensuse] rootmail does not work, no matter what


On 25/09/2017 08:44, Per Jessen wrote:
Dave Plater wrote:

I just tried to send mail from root to root and it failed, I have my
user set up to receive root mail from first installation.

I'm not sure (because I don't use that setting), but I think this is
just a line in /etc/aliases that directs root to your user account.

Note if logged in as root I enter mail, and there's no mail, it's
reply is no mail for user davepl.

Interesting. There must be more to it than a change of aliases.

I tried root root and no mail, root davepl, the mail arrives, davepl
root I get a non delivery notification. Therefore the root account
doesn't exist for receiving mail on my Leap:42.3 system. I suspect
this is as a result of the setting for user to receive root mail.

What does that NDR say ?



I read the man page and found the p command, the report says:
Message 1:
From MAILER-DAEMON Mon Sep 25 09:29:59 2017
Envelope-to: davepl@Arbuthnot
Delivery-date: Mon, 25 Sep 2017 09:29:59 +0200
X-Failed-Recipients: root@Arbuthnot
Auto-Submitted: auto-replied
From: Mail Delivery System <Mailer-Daemon@Arbuthnot>
To: davepl@Arbuthnot
Content-Type: multipart/report; report-type=delivery-status; boundary=1506324598-eximdsn-1157301043
MIME-Version: 1.0
Subject: Mail delivery failed: returning message to sender
Date: Mon, 25 Sep 2017 09:29:59 +0200

Part 1:
Content-type: text/plain; charset=us-ascii

This message was created automatically by mail delivery software.

A message that you sent could not be delivered to one or more of its
recipients. This is a permanent error. The following address(es) failed:

root@Arbuthnot
retry timeout exceeded

Part 2:
Content-type: message/delivery-status


Part 3:
Content-type: message/rfc822

From davepl@Arbuthnot Mon Sep 25 09:29:58 2017
Date: Mon, 25 Sep 2017 09:29:58 +0200
From: davepl@Arbuthnot
To: root@Arbuthnot
Subject: Test5
User-Agent: Heirloom mailx 12.5 7/5/10
MIME-Version: 1.0
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit

12345678
~
~
Seems the root account doesn't exist.
Dave P

--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >