Mailinglist Archive: opensuse (946 mails)

< Previous Next >
Re: [opensuse] some mp4 cannot be played "decoder profile above limits"


On 24/09/2017 11:13, Daniel Bauer wrote:


Am 24.09.2017 um 10:31 schrieb Dave Plater:


On 23/09/2017 19:01, Daniel Bauer wrote:
Thank you for the explanations. After reading a bit thru the links, I found out that my Nvidia Card (GeForce GTX 460) only supports Nvidia VDPAU Feature Set C, which is up to 1920x1080px, and with that I can explain myself why one video worked and the other didn't...

Still I wonder what has changed that vlc before played all my videos without complaining. Probably as you said, it changed the behavior of its "automatic" or somehow the settings were changed. It wasn't me!

Daniel

One more thing to see if it is in fact due to the ffmpeg2 update.
I've built an earlier version version 2.8.11.
Can you force install it to try. The easiest way to do this is to install the ffmpeg-2-devel package from :
http://pmbs-api.links2linux.org:8080/home:/davepl/Leap_42.3/
and accept all the downgrade options. To upgrade again simply install the ffmpeg2-devel package from Packman. You can remove the devel package afterwards if you wish, it conflicts all the ffmpeg devel packages.

Dave P


Ok, I installed the ffmpeg-2-devel from your repo. But behavior then was as before (not playing the video).

Anyway, I don't know about the ffmpeg2. There was nothing ffmpeg2-like installed before, only ffmpeg. Apart of devel and debug packages I also cannot see anything ffmpeg2 related in yast.

The ffmpeg2 package provides libavcodec56, libavdevice56, libavfilter5, libavformat56 etc for vlc. The current ffmpeg provides libavcodec57, libavdevice57, libavresample3, libavdevice57, libavformat57 etc for everything else. After installing ffmpeg2-devel-2.8.11 you should now have libavcodec56 = 2.8.11
libavdevice56 = 2.8.11
libavfilter5 = 2.8.11
libavformat56 = 2.8.11
libavresample2 = 2.8.11
libavutil54 = 2.8.11
libpostproc53 = 2.8.11
libswresample1 = 2.8.11
libswscale3 = 2.8.11
Installed which is two versions lower than the current 2.8.13.
If you still get the same problem then it's not due to the update.
BTW I still had the old version installed but I tested with the current version and vlc still worked with intel graphics.
Hope this makes sense.
Dave P

--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups