Mailinglist Archive: opensuse (946 mails)

< Previous Next >
[opensuse] Black screen when plugging in VGA connector
Hi all,

I have a Thinkpad X200 (Librebooted) that I'm faffing about with.
Everything works as it ought, except I get some odd behaviour when I
plug in a VGA connector. A moment after it is plugged in, the screen on
the laptop goes black, except I can still see (and move) the cursor
within the bounds of the laptop screen. The external monitor is also
completely black. The cursor flickers a little bit.

After I unplug the VGA connector, everything goes back to normal.

This only happens when there is an actual monitor on the other end of
the cable. Plugging in a loose cable does nothing. I haven't yet tried
to connect to a different monitor.

I have the output of `journalctl` during the behaviour here:

http://susepaste.org/39924818

Particularly, this line sticks out to me:

Sep 23 21:31:02 carmen-thinkpad kernel:
[drm:intel_cpu_fifo_underrun_irq_handler [i915]] *ERROR* CPU pipe A FIFO
underrun

But it's not something I know how to interpret.

I have tried:

- Using IceWM instead of Gnome.

- Using LightDM instead of GDM.

- Using the VGA port on the dock instead of on the laptop.

None of the above yielded positive results.

Maybe someone can help me?

Yours with gratitude,

--
Carmen Bianca Bakker
en eo fy nl
< Previous Next >