Mailinglist Archive: opensuse (946 mails)

< Previous Next >
Re: [opensuse] some mp4 cannot be played "decoder profile above limits"


Am 23.09.2017 um 18:05 schrieb David Haller:
Hello,

On Sat, 23 Sep 2017, Daniel Bauer wrote:
Am 23.09.2017 um 16:42 schrieb David Haller:
On Sat, 23 Sep 2017, Daniel Bauer wrote:
I tried to start from commandline, and maybe the messages say something to
somebody of you...:

vlc 20161005_085414.mp4
VLC media player 2.2.6 Umbrella (revision 2.2.6-0-g1aae78981c)
[00007f236c0b6378] vdpau_avcodec generic error: decoder profile above limits:
^^^^^^^^^^^^ ^^^^^^^^^^^^^^^^^^^^^^^^^^^^
level 51 3840x2160

Easy and _very_ specific. You selected vdpau output (i.e. have your
GPU decode the videostream via vdpau), but your GPU does not support
the encoding-profile ((only constant) bitrate, framerate, various
codec details) that is used in your video. Your GPU/driver just
implements some basic profiles of the codec.

Hm. Then I wonder why it worked before? It always worked, and I used it many
times. I haven't changed anything on the hardware. But maybe a nvidia-update
has forgotten about things it could manage before?

I doubt that. I guess on a new default to use vdpau if available in
either vlc or ffmpeg. Or both.

I've checked your vid by now and it's H.264. And that codec has _a
lot_ of parameters, and GPUs implement just a few specific sets of
combinations. It's a bit like picking a few specific colours (say, the
classic 8 or 256 console-colors) out of what can be done with RGB
w/8bits per channel. Your GPU (decoding) is a bit like an old terminal
that can display those 256 colours, but fails at displaying other
colours ("out of limits" ;). And for "encoding" with the GPU, it's
usually even more limited to some 2 or 3 profiles ("Low", "High" and
with strictly specified parameters) , as if it'd support just 8
colours.

See also:
https://en.wikipedia.org/wiki/VDPAU
https://en.wikipedia.org/wiki/VDPAU#Nvidia_VDPAU_Feature_Sets
https://en.wikipedia.org/wiki/Video_Acceleration_API
https://en.wikipedia.org/wiki/Video_Acceleration_API#Supported_video_codecs
https://en.wikipedia.org/wiki/X-Video_Bitstream_Acceleration
So use a different decoder, i.e. one without "vdpau". Not sure where
that setting is found in vlc, probably either in
simple view:
Video -> Output
"all" view:
Video -> Output modules
in the preferences.

...

So I changed the Video -> Output setting in vlc from "automatic" to "OpenGL
GLX Videoausgabe (XCB)" I've chosen this arbitrary because it sounded the
nicest to me, but in fact I have no idea... :-) .

Good choice. AFAIR it is the fastest and most versatile output module.

For mplayer, use 'vo=gl2,gl,xv,x11' in your ~/mplayer/config.

For xine, it's 'opengl2'.

With this setting it works.

*hehe* :)

HTH,
-dnh


Thank you for the explanations. After reading a bit thru the links, I found out that my Nvidia Card (GeForce GTX 460) only supports Nvidia VDPAU Feature Set C, which is up to 1920x1080px, and with that I can explain myself why one video worked and the other didn't...

Still I wonder what has changed that vlc before played all my videos without complaining. Probably as you said, it changed the behavior of its "automatic" or somehow the settings were changed. It wasn't me!

Daniel
--
Daniel Bauer photographer Basel Barcelona
https://www.patreon.com/danielbauer
http://www.daniel-bauer.com

--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups