Mailinglist Archive: opensuse (946 mails)

< Previous Next >
Re: [opensuse] some mp4 cannot be played "decoder profile above limits"


Am 23.09.2017 um 16:42 schrieb David Haller:
Hello,

On Sat, 23 Sep 2017, Daniel Bauer wrote:
I tried to start from commandline, and maybe the messages say something to
somebody of you...:

vlc 20161005_085414.mp4
VLC media player 2.2.6 Umbrella (revision 2.2.6-0-g1aae78981c)
[00007f236c0b6378] vdpau_avcodec generic error: decoder profile above limits:
^^^^^^^^^^^^ ^^^^^^^^^^^^^^^^^^^^^^^^^^^^
level 51 3840x2160

Easy and _very_ specific. You selected vdpau output (i.e. have your
GPU decode the videostream via vdpau), but your GPU does not support
the encoding-profile ((only constant) bitrate, framerate, various
codec details) that is used in your video. Your GPU/driver just
implements some basic profiles of the codec.

Hm. Then I wonder why it worked before? It always worked, and I used it many times. I haven't changed anything on the hardware. But maybe a nvidia-update has forgotten about things it could manage before?

So use a different decoder, i.e. one without "vdpau". Not sure where
that setting is found in vlc, probably either in
simple view:
Video -> Output
"all" view:
Video -> Output modules
in the preferences.

...

So I changed the Video -> Output setting in vlc from "automatic" to "OpenGL GLX Videoausgabe (XCB)" I've chosen this arbitrary because it sounded the nicest to me, but in fact I have no idea... :-) .

With this setting it works.

Still I wonder why it worked before with the "autmomatic" setting and now doesn't anymore...

--
Daniel Bauer photographer Basel Barcelona
https://www.patreon.com/danielbauer
http://www.daniel-bauer.com

--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups