Mailinglist Archive: opensuse (946 mails)

< Previous Next >
Re: [opensuse] some mp4 cannot be played "decoder profile above limits"


Am 23.09.2017 um 13:20 schrieb michael norman:
On 23/09/17 10:43, Daniel Bauer wrote:
Hi everybody

"Suddenly" the mp4-videos from my mobile phone cannot be played anymore, no matter what player I use: it only shows a black screen plus plays the sound, but no image.

As for my small tests it only affects the mp4 from my samsung mobile that are larger than 10MB (9.8MB works, 11.2MB does not work, neither larger). But downloaded mp4, avi, etc. work normally even in GB size.

I tried to start from commandline, and maybe the messages say something to somebody of you...:

vlc 20161005_085414.mp4
VLC media player 2.2.6 Umbrella (revision 2.2.6-0-g1aae78981c)
[000055aac07500c8] core libvlc: VLC wird mit dem Standard-Interface ausgeführt. Benutzen Sie 'cvlc', um VLC ohne Interface zu verwenden.
[00007f236c0b6378] vdpau_avcodec generic error: decoder profile above limits: level 51 3840x2160
[00007f236c0c48b8] freetype spu text error: Breaking unbreakable line
QObject::~QObject: Timers cannot be stopped from another thread

I see a limit, but don't know where I can change this limit. Everything worked a few weeks ago with the same system, but meanwhile there were some updates and of course I have no idea which one changed that...

Leap 42.3
KDE 5.8.7
Kernel 4.4.87-25 default
Latest "zypper up" done 5 minutes ago.

All "media-things" installed from packman.

Any hints? Thanks!

Daniel

What is the source of your downloaded mp4 etc files.  I use Get_Iplayer to download BBC programmes from the BBC iplayer, using 42.3 VLC, Kodi etc as players all installed from packman via the OpenSuse box.  I "can" play them on my Android tablet but its a long time since I tried that so that device "might" have the limitations you describe.

Are you downloading the files using the phone ?  How are you trying to watch them, ie on which device ?

All I can suggest is a problem with the phone maybe.

M


No, these are videos I took with the phone and copied to the desktop computer. I could always watch them on the desktop using vlc. Now I cannot watch them anymore with the described problem.

The others (that work in vlc) are from many various sources. It just affects those from my phone. And they haven't been affected some weeks ago. I can still play them in a browser or using QTAV, but not vlc or kaffeine.

Meanwhile I found out that it seems that only videos taken before June 12th 2017 are affected. Newer ones play...

I uploaded two sample videos taken with the same phone - nothing interesting, download only worthwhile if you'd like to test but not for the content :-) :

does /NOT/ work in VLC:
https://www.daniel-bauer.com/test/20170603_124912.mp4 (14.3MB)

plays normal:
https://www.daniel-bauer.com/test/20170612_160315.mp4 (29.8MB)

--
Daniel Bauer photographer Basel Barcelona
https://www.patreon.com/danielbauer
http://www.daniel-bauer.com

--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >