Mailinglist Archive: opensuse (946 mails)

< Previous Next >
Re: [opensuse] Apache Start Up Problem
  • From: Per Jessen <per@xxxxxxxxxxxx>
  • Date: Sat, 09 Sep 2017 11:41:20 +0200
  • Message-id: <op0d01$cm3$1@saturn.local.net>
Paul Groves wrote:



On 08/09/17 17:35, Per Jessen wrote:
Paul Groves wrote:

I had a weird problem today. I noticed that after a reboot of my
server, my owncloud instance on my desktop was complaining about an
invalid certificate. I tried to 'open owncloud in browser' and was
presented with my apache default page.

So first thing I tried is restart the apache service. This fixed the
problem. However, every time I reboot apache is not loading my
configuration correctly and the problem repeats.

It appears to be loading the default configuration file fine at boot
but ignoring the other files. (including owncloud). But when I
manually stop and start the service they load fine. Huh??

Any idea how I can diagnose what is causing this problem?

What is the difference between the apache service loading at boot
compared to manually starting the service?
Assuming by "manually starting the service" you mean "systemctl start
apache2", there should be no difference.
systemctl start apache2 or service apache2 start

How does a service load at boot? I do not understand how it can be
missing a configuration file on load.

If your config files were on a filesystem still to be mounted when
apache starts (on a reboot), but that's a bit far fetched I would say.

On a reboot, before you restart apache2, investigate how it was
started - which arguments etc. There must be some sort of difference
to a manual restart.


--
Per Jessen, Zürich (14.1°C)
http://www.hostsuisse.com/ - virtual servers, made in Switzerland.


--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >
References