Mailinglist Archive: opensuse (946 mails)

< Previous Next >
Re: [opensuse] Leap 42.3 wants nvidia
Am 01.09.2017 um 13:22 schrieb Roger Oberholtzer:
I was just going to do a 'zypper dup' on a Leap 42.3 system, and
zypper now reports this:

The following 4 NEW packages are going to be installed:
nvidia-computeG04 nvidia-gfxG04-kmp-default nvidia-glG04 x11-video-nvidiaG04

I do not have any nvidia stuff installed. Also, the nvidia RPMS are
for an older Leap kernel. I guess some other package is pulling this
in. But no other packages look like they should do this. Except
perhaps VirtualBox, which is getting updated.

Strange.

The packages themseves contain criteria that gets them installed.

I learned abou that possibility on the opensuse-factory mailing list,
when DimStar wrote (Message-id: <1503390056.32051.6.camel@xxxxxxxxxxxx>):
---snip---
That is 'reverse' - actually nothing recommends lifecycle-data-
openSUSE, but the package itself recommends its installation based on
other packages being present:

Supplements: packageand(openSUSE-release:zypper-lifecycle-plugin)

so, as soon as openSUSE-release and zypper-lifecycle-plugin are being
installed on the system, lifecycle-data-openSUSE is being marked as a
recommended package.
---pins---

That is what works with the nvidia repo at
<https://download.nvidia.com/opensuse/tumbleweed> also, as described in
<20170809135610.ep2aab4ocqkfvbpo@xxxxxxx> and the messages following
this thread on opensuse-factory mailing list (starting 2017-08-09).

Werner
--

--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >
References