Mailinglist Archive: opensuse (1264 mails)

< Previous Next >
Re: [opensuse] Tape Drive Trouble
On 21/06/17 21:51, Greg Freemyer wrote:

From what you describe, I don't think it is the tape drive has failed
or needs cleaning because those wouldn't fix themselves by moving from
one server to another.
I tried a different SCSI card and cable borrowed from a friend in the server and the problem is still there with both drives. I have since tried the drives in the other server (where they did work) and now they don't. Perhaps there is some muck in the drive and moving shook it loose?
1) Have you tried the drive as the only device on the SCSI bus? I've
seen lots of problems go away once the other drives are pulled from
the bus. Not always a great solution, but it helps with
troubleshooting.
Yes, with both problem drives, no difference in the fault(s)
2) I gather you have a physical terminator at the far end of the bus.
You haven't talked about the terminator at the other end of the SCSI
bus. ie. SCSI requires 2 terminators, one at each end of the bus.
Your SCSI controller should have a setting that enables/disables the
terminator built into the controller.
I have a physical terminator on the far end. As for the controller end, I never knew this existed but the drives have worked fine for over a year with the current configuration.

How would I check this setting (if the card has this option).
3) You've moved the tape drive to another computer and it worked.
Have you moved the cable and the drive as a pair?
I didn't at first, then I did and it worked. But as I mentioned above now it does not work in the other server anymore.
4) Have you tried a different addresses? Have you reset the address
pins and/or swapped them between drives. I've seen address failures
in the past. The address pins are binary. You said you have 0, 1, 2,
3. That's 4 bits, so you can pick any address from 0 to 15 if you
have 4 jumper pins to work with. Just make sure you don't have an
address collision between the controller and the various drives.

I have checked these. My settings are

DAT72 - 0000
LTO1 - 0001
LTO2 - 0010
LTO3 / 4 (when I swap them they have the same ID) - 0011

The SCSI Controlled PCI card is - 0111 (7) which cannot be changed.

Good Luck
Greg

I am now suspecting this is not an SCSI problem as with two different cables / servers / SCSI controllers the problem is only the LTO3 and 4 drives, so it must be a problem with the drives.

--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups