Mailinglist Archive: opensuse (1264 mails)

< Previous Next >
Re: [opensuse] Tape Drive Trouble
On Tue, Jun 20, 2017 at 12:55 PM, Paul Groves <paul.groves.787@xxxxxxxxx> wrote:
Hi,

I have 4 tape drives in my server and I am lately experiencing a few problems.

One night a backup failed with rmtio failed: Input output Error. I
ran it again and it worked.

This has happened more and more frequently and now the drive fails
writing every time with this error. I put the drive (Hp storageworks
Ultrium 920) in another server. It works fine.

I have just received a storageworks ultrium 1760 drive today. Same
problem is occuring.

The easiest way to make the error come up is to try mt -f /dev/st3 erase

The drive sounds like it erases the tape, then the tape is unloaded
and goes back in again automatically. Then it erases it again, then
does it again then again and again then eventually it gives up with
the message mt: /dev/st3: rmtioctl failed: Input/output error

Can anyone enlighten me, what exactly is an mt: rmtio: Input/output
error and how can I diagnose where exactly this error is occuring.

I have tried disconnecting all other drives on the SCSI bus and only
connecting the one scsi drive. I have also tried a different scsi
connector on the same cable (which is where another drive that works
fine is usually connected).

I thought could this be a fault with the cable or the controller? But
why would the other 3 drives work fine? Then I thought but if the
problem is with my two drives why do they both work in another server?

I have also tried connecting one of my working drives to each SCSI
connector on the cable in turn and it works fine on every one of them,
so surely it is not the SCSI controller or cable?

Answers to the obvious:

The drive jumper pins are correct
I do have a terminator on the end of the SCSI cable
I have tried more than one tape
I have ran several cleaning cartridges in each drive.
There are no error LEDs on the drives
I have already tried turning it off and on again :)


Please can anyone assist with this? I am completely stumped.

Paul,

I've had lots of SCSI issues with tape drives over the years.

From what you describe, I don't think it is the tape drive has failed
or needs cleaning because those wouldn't fix themselves by moving from
one server to another.

1) Have you tried the drive as the only device on the SCSI bus? I've
seen lots of problems go away once the other drives are pulled from
the bus. Not always a great solution, but it helps with
troubleshooting.

2) I gather you have a physical terminator at the far end of the bus.
You haven't talked about the terminator at the other end of the SCSI
bus. ie. SCSI requires 2 terminators, one at each end of the bus.
Your SCSI controller should have a setting that enables/disables the
terminator built into the controller.

3) You've moved the tape drive to another computer and it worked.
Have you moved the cable and the drive as a pair?

4) Have you tried a different addresses? Have you reset the address
pins and/or swapped them between drives. I've seen address failures
in the past. The address pins are binary. You said you have 0, 1, 2,
3. That's 4 bits, so you can pick any address from 0 to 15 if you
have 4 jumper pins to work with. Just make sure you don't have an
address collision between the controller and the various drives.

Good Luck
Greg

--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups
References