Mailinglist Archive: opensuse (1264 mails)

< Previous Next >
[opensuse] Tape Drive Trouble
  • From: Paul Groves <paul.groves.787@xxxxxxxxx>
  • Date: Tue, 20 Jun 2017 17:55:10 +0100
  • Message-id: <CAMBjXVQwe6AA-f2NwEb-1z9JCng7=PXzcuoXwsK=1e_Cc8Yg_w@mail.gmail.com>
Hi,

I have 4 tape drives in my server and I am lately experiencing a few problems.

One night a backup failed with rmtio failed: Input output Error. I
ran it again and it worked.

This has happened more and more frequently and now the drive fails
writing every time with this error. I put the drive (Hp storageworks
Ultrium 920) in another server. It works fine.

I have just received a storageworks ultrium 1760 drive today. Same
problem is occuring.

The easiest way to make the error come up is to try mt -f /dev/st3 erase

The drive sounds like it erases the tape, then the tape is unloaded
and goes back in again automatically. Then it erases it again, then
does it again then again and again then eventually it gives up with
the message mt: /dev/st3: rmtioctl failed: Input/output error

Can anyone enlighten me, what exactly is an mt: rmtio: Input/output
error and how can I diagnose where exactly this error is occuring.

I have tried disconnecting all other drives on the SCSI bus and only
connecting the one scsi drive. I have also tried a different scsi
connector on the same cable (which is where another drive that works
fine is usually connected).

I thought could this be a fault with the cable or the controller? But
why would the other 3 drives work fine? Then I thought but if the
problem is with my two drives why do they both work in another server?

I have also tried connecting one of my working drives to each SCSI
connector on the cable in turn and it works fine on every one of them,
so surely it is not the SCSI controller or cable?

Answers to the obvious:

The drive jumper pins are correct
I do have a terminator on the end of the SCSI cable
I have tried more than one tape
I have ran several cleaning cartridges in each drive.
There are no error LEDs on the drives
I have already tried turning it off and on again :)


Please can anyone assist with this? I am completely stumped.

--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >