Mailinglist Archive: opensuse (1264 mails)

< Previous Next >
Re: [opensuse] Epson Scanner V500 Isn't Detected
On 2017-06-19 13:22, Mark Misulich wrote:
On Mon, 2017-06-19 at 12:17 +0200, Aaron Digulla wrote:
Am Sonntag, Juni 18, 2017 23:39 CEST, Mark Misulich <munguanaweza@gma
il.com> schrieb:


There is a kernel/sane bug which breaks many USB scanners. Make sure
you have at least version 1.0.25 of SANE installed.
I installed sane-backends version 1.0.27 from Sauerland OBS repository,
but the scanner still isn't recognized in yast Scanner configuration
window.

Driver Scanner
epkowa Epson (unknown model) at epkowah:usb001:004
Not Configured EPSON Scanner USB scanner (vendor=0x04b8 [EPSON],
product=0x0130
[EPSON Scanner]) at libusb:001:004

From http://www.sane-project.org/
The Linux USB3 workaround which was added in version 1.0.25 is now
disabled by default. If you have difficulty using a scanner which
previously worked, or intermittent scanner availability, try setting
the new environment variable SANE_USB_WORKAROUND=1 before starting
your frontend.
I don't know where to do this, I will need more detailed instructions.
Use sane-find-scanner and "scan-image -L" on the command line to see
whether SANE can see the scanner.

Here are the readouts:

sane-find-scanner

SANE_USB_WORKAROUND=1 sane-find-scanner

etc.


scanimage -L
device `epkowa:usb:001:004' is a Epson (unknown model) flatbed scanner

SANE_USB_WORKAROUND=1 scanimage -L

etc

--
Cheers / Saludos,

Carlos E. R.
(from 42.2 x86_64 "Malachite" at Telcontar)

< Previous Next >
References