Mailinglist Archive: opensuse (1264 mails)

< Previous Next >
Re: [opensuse] Update FireFox 49.5 -> 52.2, file dialogs are horrible, how to get FF49 dialogs back?
On 06/14/2017 08:48 PM, Felix Miata wrote:
David C. Rankin composed on 2017-06-14 21:21 (UTC-0400):
.
I updated to firefoxe 52.5esr from 49.5esr. One thing that is just totally
repugnant is the file->open dialog. It is per-se unusable.
.
How do I get the file->open dialog from 49.5 back? -- or at least get this
damn thing to sort the folders first like every other sane file->open dialog
does. I have folders with 20 or so directories and 1400+ files in them and
trying to navigate where you have to scroll through 1200 files just to get to
the 'tst' directory is unacceptable.

Is there some setting that controls this? Right now this thing is
unnavigable with scores of .zip files mixed with directories mixed with files
in an unholy mess. Why when I first scroll down with the mouse are many of
the
icons missing?
.
Help....
.
(screenshot of the dialog I see at, http://paste.opensuse.org/5398449)
.
I think I know why, but not if there is anything you can do about it. Check
about:buildconfig. If you don't see cairo-gtk2 or if you do see the string
gtk3,
that's almost certainly the why for the change. Check in about:config if
ui. allow_platform_file_picker
is set and what to. http://kb.mozillazine.org/About:config_entries might be
obsolete.


What are the mozilla folks thinking?

MOZ_AUTOMATION=1 --enable-update-channel=esr
PKG_CONFIG=/builds/slave/m-esr52-l64-000000000000000000/build/src/gtk3/usr/local/bin/pkg-config
MOZ_PGO=1
CC=/builds/slave/m-esr52-l64-000000000000000000/build/src/gcc/bin/gcc
CXX=/builds/slave/m-esr52-l64-000000000000000000/build/src/gcc/bin/g++
--enable-rust
RUSTC=/builds/slave/m-esr52-l64-000000000000000000/build/src/rustc/bin/rustc
CARGO=/builds/slave/m-esr52-l64-000000000000000000/build/src/cargo/bin/cargo
--enable-js-shell --enable-default-toolkit=cairo-gtk3
--with-mozilla-api-keyfile=/builds/mozilla-desktop-geoloc-api.key
--with-google-api-keyfile=/builds/gapi.data MAKE=/usr/bin/gmake
--enable-crashreporter --enable-elf-hack --enable-official-branding
--enable-release --enable-stdcxx-compat --enable-verify-mar

There is nothing but the 1/2 baked gtk3 toolkit crud included. I don't care
what version it is, I just want usable dialogs. It is incredibly frustrating
to have to mouse down 50 times just to get the next directory you need to
navigate to, to then scroll down another 30 screens to get to the next.

I sure hope there is a ~/.config/gtk-3.0/settings.ini setting that will fix
this, but I haven't been able to find it yet.

I wonder if buildservice could compile a version witih gtk+2 dialogs enabled.
This is KDE-4.04 bad... (and that was really, really bad...)

--
David C. Rankin, J.D.,P.E.

--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >