Mailinglist Archive: opensuse (1264 mails)

< Previous Next >
[opensuse] no wireless in new laptop
My old laptop broke, failed motherboard... so had to purchase a new one...

Here I am with a Dell Inspiron 15 5576...

I have installed leap 42.2, going with gnome for the time being...

but, cannot get wireless card to work, and as of now I don't have an ethernet cable to connect it directly to the router.

Here is what I am seeing -

------------------------
# hwinfo --netcard
30: PCI 100.0: 0282 WLAN controller
[Created at pci.374]
Unique ID: y9sn.D6QMyC7dbb5
Parent ID: jDmU.XZwpGIabNM5
SysFS ID: /devices/pci0000:00/0000:00:02.2/0000:01:00.0
SysFS BusID: 0000:01:00.0
Hardware Class: network
Model: "Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter"
Vendor: pci 0x168c "Qualcomm Atheros"
Device: pci 0x003e "QCA6174 802.11ac Wireless Network Adapter"
SubVendor: pci 0x1028 "Dell"
SubDevice: pci 0x0310
Revision: 0x32
Driver: "ath10k_pci"
Driver Modules: "ath10k_pci"
Device File: wlan0
Features: WLAN
Memory Range: 0xfe400000-0xfe5fffff (rw,non-prefetchable)
IRQ: 232 (no events)
HW Address: d8:0f:99:74:e6:d5
Link detected: no
WLAN channels: 1 2 3 4 5 6 7 8 9 10 11 12 13 36 40 44 48 52 56 60 64 100 104 108 112 116 120 124 128 132 136 140
WLAN frequencies: 2.412 2.417 2.422 2.427 2.432 2.437 2.442 2.447 2.452 2.457 2.462 2.467 2.472 5.18 5.2 5.22 5.24 5.26 5.28 5.3 5.32 5.5 5.52 5.54 5.56 5.58 5.6 5.62 5.64 5.66 5.68 5.7
WLAN encryption modes: WEP40 WEP104 TKIP CCMP
WLAN authentication modes: open sharedkey wpa-psk wpa-eap
Module Alias: "pci:v0000168Cd0000003Esv00001028sd00000310bc02sc80i00"
Driver Info #0:
Driver Status: ath10k_pci is active
Driver Activation Cmd: "modprobe ath10k_pci"
Config Status: cfg=no, avail=yes, need=no, active=unknown
Attached to: #12 (PCI bridge)
---------------------------

So the driver for the wireless card is ath10k_pci. The firmware didn't load, properly, so I tried to upgrade to the latest firmware.

Original package - kernel-firmware 20160516git-3.1
upgraded package - kernel-firmware 20160516git-5.1

However, after upgrading the firmware, it still didn't load, as you can see from this segment of dmesg:

-----------------------
> dmesg | grep ath
[ 14.391171] ath10k_pci 0000:01:00.0: enabling device (0000 -> 0002)
[ 14.392760] ath10k_pci 0000:01:00.0: pci irq msi-x interrupts 8 irq_mode 0 reset_mode 0
[ 14.648202] ath10k_pci 0000:01:00.0: Direct firmware load for ath10k/cal-pci-0000:01:00.0.bin failed with error -2
[ 14.648439] ath10k_pci 0000:01:00.0: Direct firmware load for ath10k/QCA6174/hw3.0/firmware-5.bin failed with error -2
[ 14.648444] ath10k_pci 0000:01:00.0: could not fetch firmware file 'ath10k/QCA6174/hw3.0/firmware-5.bin': -2
[ 15.197783] ath10k_pci 0000:01:00.0: failed to fetch board data for ath10k/QCA6174/hw3.0 from bus=pci,vendor=168c,device=003e,subsystem-vendor=1028,subsystem-device=0310/board-2.bin
[ 17.341715] ath10k_pci 0000:01:00.0: qca6174 hw3.2 (0x05030000, 0x00340aff sub 1028:0310) fw WLAN.RM.2.0-00180-QCARMSWPZ-1 fwapi 4 bdapi 1 htt-ver 3.26 wmi-op 4 htt-op 3 cal otp max-sta 32 raw 0 hwcrypto 1 features wowlan,ignore-otp,no-4addr-pad
[ 17.341723] ath10k_pci 0000:01:00.0: debug 0 debugfs 0 tracing 0 dfs 0 testmode 0
[ 18.341839] ath10k_pci 0000:01:00.0: suspend timed out - target pause event never came
[ 18.409466] ath: EEPROM regdomain: 0x6c
[ 18.409472] ath: EEPROM indicates we should expect a direct regpair map
[ 18.409475] ath: Country alpha2 being used: 00
[ 18.409475] ath: Regpair used: 0x6c
[ 28.045746] ath10k_pci 0000:01:00.0: failed to enable adaptive qcs: -11
[ 31.045656] ath10k_pci 0000:01:00.0: could not suspend target (-11)
[ 36.709605] ath10k_pci 0000:01:00.0: failed to set rx-chainmask: -11, req 0x3
[ 39.709679] ath10k_pci 0000:01:00.0: failed to set arp ac override parameter: -11
[ 42.709541] ath10k_pci 0000:01:00.0: could not suspend target (-11)
[ 48.017549] ath10k_pci 0000:01:00.0: failed to enable adaptive qcs: -11
--------------------------

So I am thinking, maybe I need to get a newer kernel. The kernel I am using is the one that came with the leap 42.2 install dvd. So I downloaded the newest kernel from the kernel:stable repository, but on trying to upgrade, here is what I get:

--------------------------
# zypper up kernel-default
Loading repository data...
Reading installed packages...
There is an update candidate for 'kernel-default', but it is from a different vendor. Use 'zypper install kernel-default-4.11.4-1.1.gcba98ee.i586' to install this candidate.
Resolving package dependencies...

Nothing to do.


# zypper install kernel-default-4.11.4-1.1.gcba98ee.i586
Loading repository data...
Reading installed packages...
Resolving package dependencies...

Problem: This request will break your system!
kernel-default-4.11.4-1.1.gcba98ee.i586 conflicts with libc.so.6()(64bit) provided by glibc-2.22-3.7.x86_64

Solution 1: Following actions will be done:
ignore the warning of a broken system (requires:glibc)
do not install kernel-default-4.11.4-1.1.gcba98ee.i586
Solution 2: do not install kernel-default-4.11.4-1.1.gcba98ee.i586

Choose from above solutions by number or cancel [1/2/c] (c): 2
Resolving dependencies...
Resolving package dependencies...

Nothing to do.
----------------------------

This is where I have reached the end of the road. I cannot uninstall glibc, can I? I mean, that is probably a pretty critical package, with a ton of libraries that the system needs.

What can I try? Anything I do I have to download on a different computer, put on a stick, and then put then put the stick in the new computer, and do the package install from there. The new computer cannot connect to the internet until I get wireless installed. I might be able to go out and purchase an ethernet cable later and see if then the ethernet can connect, but I don't know when that will be.

So, any help would be greatly appreciated! :)

--
George
Box: 42.2 | KDE Plasma 5.8 | AMD Phenom IIX4 | 64 | 32GB
Laptop #1: 42.2 | gnome | AMD FX 7th gen | 64 | 12GB
Laptop #2: 42.2 | KDE Plasma 5.8 | Core i5 | 64 | 8GB

--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups