Mailinglist Archive: opensuse (856 mails)

< Previous Next >
Re: [opensuse] System slowdowns
On October 9, 2016 9:58:12 AM PDT, Marc Chamberlin <marc@xxxxxxxxxxxxxxxxxx>
wrote:
On 10/5/2016 12:37 AM, John Andersen wrote:
On 10/04/2016 11:21 PM, Marc Chamberlin wrote:
On 10/4/2016 6:04 PM, John Andersen wrote:
On 10/04/2016 05:29 PM, Marc Chamberlin wrote:
The mouse problems seem worth investigating. Maybe dig in the
junk drawer for a totally
different kind of mouse (serial, bluetooth, usb-wired) and see if
that changes anything.

Thanks John for your suggestion. I tried a different mouse and no
joy... Marc....

Remind me again what kernel you are using, and what version of
Vbox?
I tend to purge my list mail fairly aggressivly.
Hi John - I am running Leap 42.1 (x86_64) I am not running VBox,
(which I think what you are
referring to is VirtualBox?) Interesting that you should ask though
because I am playing around with
Docker. However, I don't think my system slowdowns has anything to
do with Docker as these slowdown
issues preceded my installation of Docker. And these slowdowns occur
regardless of whether Docker is
running or not. (The only reason I am fooling around with Docker,
FYI, is so I can get the latest
version of the Apache James email server up and running, something
that OpenSuSE does not directly
support.)

Marc....



So that was originally kernel 4.1. Are you still on that or have you
upgraded?

It might be worth trying to boot with
iomem=relaxed

added to the kernel command line.

It might not do anything but slowness has been detected in several
distros
as soon as kernel updates were applied due to tighter memory
security.




Thanks John for the thought, I tried adding the iomem=relaxed option to

the kernel options using the Yast Boot Loader tool, rebooted, and still

no joy...

In my fooling around with this issue, I have come across something that

definitely triggers high CPU usage, and could be a clue. Although I
cannot definitively say this is the smoking gun because I see high
system CPU usage going on regardless of whether I do this or not -

There is something very wrong going on when I use Dolphin to move stuff

to the trash "Recycle Bin" (or sometimes it appears when I use Dolphin
to simply move files from one location to another, i.e. drag and drop)
and/or when I tell Dolphin to empty the trash. Doing so kicks off the
100% CPU usage and I hear the processor cooling fans kick into high
speed. These tasks can take hours or even days to complete (if ever,
some are still going on for over a week now. When I reboot the system,
these tasks are not initially restarted, but if I do something like
open
the Recycle Bin to see if the files are still in it (after I told
Dolphin to empty the trash) then these processes again kick off and the

CPU usage goes up to 100%. The two (or more) spawned processes of
interest are file.so and trash.so. However, unlike my original report
and observations, these processes do report very high CPU usage also in

the Process Table tab of KSystemGuard, top, atop, and htop so I am not
100% certain that this is related to the issue I reported - about
something hidden is causing high CPU usage.

Of interest also is doing file moves or deletes from the command line,
i.e. using the mv, rm, and rmdir commands does not cause this high CPU
usage to occur and those commands complete in a reasonable amount of
time.

Marc...


Still sounds like a disk hardware problem to me. Trash is limited to some
percentage of disk , and there shouldn't be any reason that delete operation
would take that much time.

But I suppose it's still possible a horribly corrupted file system could be at
fault, but if you never see errors that seems unlikely.

Is it still slow when you unplug / shut down your network connections
(physically unplug the cat5) ?




--
Sent from my Android phone with K-9 Mail. Please excuse my brevity.

--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >