Mailinglist Archive: opensuse (527 mails)

< Previous Next >
Re: [opensuse] which which?
On 08/29/2016 08:30 PM, Michael Fischer wrote:

Once upon a time, SuSE had a which(1) which was actually type(1) with " -a".

Recently noticed that which(1) is now actually /usr/bin/which.

Just curious, but what was the reason for the back and forth?

Best,

Michael


I get:
--- cut here ---
% which which
which: shell built-in command.
--- cut here ---

I should mention that I am using "csh" (or, really, "tcsh").

The "which" command was always a "csh" built-in.

Remembering back, if I used the Bourne shell, and tried "which" it still
worked. Checking, I found that there was a "csh" shell script on the
standard path which simply invoked the "csh" built-in.

I guess enough people have found "which" to be a useful command, that it
has now been made a binary. But, for "csh" users, it is still a built-in.

--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups
References