Mailinglist Archive: opensuse (908 mails)

< Previous Next >
Re: [opensuse] openvpn - Cannot open TUN/TAP dev /dev/net/tun: No such file or directory (errno=2)
  • From: Per Jessen <per@xxxxxxxxxxxx>
  • Date: Mon, 06 Jun 2016 20:57:03 +0200
  • Message-id: <nj4h1v$1ft$1@saturn.local.net>
Andrei Borzenkov wrote:

06.06.2016 11:21, Per Jessen пишет:
Per Jessen wrote:

Per Jessen wrote:

Andrei Borzenkov wrote:

This is probably fallout of
http://bugzilla.suse.com/show_bug.cgi?id=980324. This service
creates file (sorry, I was confused as well) based on content of
/lib/modules/$(uname -r); first time it runs in initrd when only
small number of modules is present. Due to above bug service is
not run second time after root is mounted.

Ah, I see. Yes, that makes sense. (I think).


Well, this weekend I tried the same fix -

add After=initrd.target to initrd-switch-root.target
rebuild initrd, reboot

which didn't fix the problem. Did I miss something?



I missed something. I commented on bug report.

Thanks for your effort, Andrei.

To summarize - this is fundamental problem of how systemd orders unit
start/stop that cannot really be solved without systemd change; but as
upstream refuses to admit the problem exists, it does not look like it
can be fixed.

upstream can actually ignore fact or has Poettering just not understood
the issue?


--
Per Jessen, Zürich (22.2°C)
http://www.hostsuisse.com/ - dedicated server rental in Switzerland.

--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups