Mailinglist Archive: opensuse (769 mails)

< Previous Next >
Re: [opensuse] openvpn - Cannot open TUN/TAP dev /dev/net/tun: No such file or directory (errno=2)
27.05.2016 22:59, Per Jessen пишет:
Andrei Borzenkov wrote:

27.05.2016 22:09, Per Jessen пишет:
Per Jessen wrote:

boeing:~ # systemctl status kmod-static-nodes.service
kmod-static-nodes.service - Create list of required static device
nodes for the current kernel
Loaded: loaded
(/usr/lib/systemd/system/kmod-static-nodes.service; static)
Active: active (exited) since Fri 2016-05-20 14:31:17 CEST; 1
weeks 0 days ago
Main PID: 76 (code=exited, status=0/SUCCESS)
CGroup: /system.slice/kmod-static-nodes.service

Looks good, I would say.

That service unit runs this:

/usr/bin/kmod static-nodes --format=tmpfiles
--output=/run/tmpfiles.d/kmod.conf

Looking at /run/tmpfiles.d/kmod.conf on the system where it doesnt
work:

boeing:~ # cat /run/tmpfiles.d/kmod.conf
d /dev/mapper 0755 - - -
c /dev/mapper/control 0600 - - - 10:236

From an older backlevel system:

sogo:/var/log # cat /run/tmpfiles.d/kmod.conf
c /dev/fuse 0600 - - - 10:229
c /dev/cuse 0600 - - - 10:203
c /dev/btrfs-control 0600 - - - 10:234
c /dev/loop-control 0600 - - - 10:237
d /dev/net 0755 - - -
c /dev/net/tun 0600 - - - 10:200
c /dev/ppp 0600 - - - 108:0
c /dev/uinput 0600 - - - 10:223
d /dev/mapper 0755 - - -
c /dev/mapper/control 0600 - - - 10:236
c /dev/uhid 0600 - - - 10:239
d /dev/vfio 0755 - - -
c /dev/vfio/vfio 0600 - - - 10:196
c /dev/vhci 0600 - - - 10:137
c /dev/vhost-net 0600 - - - 10:238
d /dev/snd 0755 - - -
c /dev/snd/timer 0600 - - - 116:33
d /dev/snd 0755 - - -
c /dev/snd/seq 0600 - - - 116:1


Something went rather wrong; I have fully up to date 13.2 VM and this
file has full content (including /dev/net/tun).

I'll have to patch/upgrade again, but what could have gone wrong here?
Where does kmod-static-nodes.service get its information from?

The two systems above are hardware-wise virtually identical they only
differ by CPU and memory.



This is probably fallout of
http://bugzilla.suse.com/show_bug.cgi?id=980324. This service creates
file (sorry, I was confused as well) based on content of
/lib/modules/$(uname -r); first time it runs in initrd when only small
number of modules is present. Due to above bug service is not run second
time after root is mounted. On system where it works you should see
Starting/Stopping/Starting for this service is journalctl. On system
where it does not work - only Starting once.

What is surprising that so far you are the only one who experiences this
bug (at least who complains about it).
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups