Mailinglist Archive: opensuse (769 mails)

< Previous Next >
[opensuse] network manager suddenly stopped working for no reason
On my dell XPS 13, I have a dual boot system with Windows 10. I had just restored a backup with Windows 10 and gotten it back up an running. Then I booted into opensuse (42.1, on laptop #2 below) and everything was running fine. The network was working as far as I could tell - it showed that it was connected via network manager.

So I connected a backup drive, and decided to run ntfsclone on my windows partition to the backup windows partition. I don't know why this would have anything to do with what happened next, as it seems completely unrelated, but it seemed to happen right at the same time. I typed in the command

ntfsclone --overwrite /dev/sdb3 /dev/sda3

and as soon as I hit enter, network manager gave me an indication that the network dropped off and it was trying to reconnect. It would not reconnect. It kept trying over and over, but it would not connect to the local network.

(the ntfsclone operation ran without a problem, but it just seemed to trigger the network falling off)

I tried first doing a systemctl restart NetworkManager.service, and it restarted, but it still would not connect to the network. Then I went into yast and switched over to wicked service. It found the network, and I entered the password, but it still would not connect to the network.

So I did a google search (on my other computer next to me, which is running on the network just fine), and someone suggested that I enter the command

netconfig update -f

So I did that, and it generated a resolv.conf backup file, and suddenly the network worked again while I was using wicked!

So I thought, great, now I can switch back to network manager in yast, and make network manager work again. But alas, no such easy help. When I switched back to network manager, it did the same thing as before. It would try and try to connect, but it wouldn't connect.

So I tried running netconfig update -f while network manager was running, and it didn't help. Same problem still.

So I switched back to wicked, and the network is running now, but only on wicked. I would really prefer to be able to use network manager.

Any ideas? Thanks in advance.

--
George
Box: 42.1 | KDE Plasma 5 | AMD Phenom IIX4 | 64 | 32GB
Laptop #1: 42.1 | KDE Plasma 5 | Core i7-4710HQ | 64 | 16GB
Laptop #2: 42.1 | KDE Plasma 5 | Core i5 | 64 | 8GB

--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups