Mailinglist Archive: opensuse (1470 mails)

< Previous Next >
Re: [opensuse] Why does digikam wants to become installed via zypper up?
09.02.2016 22:08, Per Jessen пишет:
Per Jessen wrote:

Andrei Borzenkov wrote:

10:~ # zypper se --requires digikam
Loading repository data...
Reading installed packages...

S | Name | Summary |
Type
--+--------------------------+-------------------------------------+------------
| Showfoto | Manage your photographs like a pr-> |
application
| digiKam | Manage your photographs like a pr-> |
application
| digikam | A KDE Photo Manager |
package
| digikam-lang | Languages for package digikam |
package
| digikam-libs | Libraries required to run digikam |
package
| digikam-plugin-color | DigiKam: ImagePlugin-Color |
package
| digikam-plugin-decorate | DigiKam: ImagePlugin-Decorate |
package
| digikam-plugin-enhance | DigiKam: ImagePlugin-Enhance |
package
| digikam-plugin-fxfilters | DigiKam: ImagePlugin-FxFilters |
package
| digikam-plugin-transform | DigiKam: ImagePlugin-Color |
package
| kipi-plugins | KDE Plug-Ins for Image Manipulation |
package
10:~ # zypper se --requires digikam-libs
Loading repository data...
Reading installed packages...

S | Name | Summary | Type
--+--------------+-------------------------------------+--------
| digikam | A KDE Photo Manager | package
| kipi-plugins | KDE Plug-Ins for Image Manipulation | package
10:~ #

So digikam is required by kipi-plugins which is going to be updated.


I removed digikam today, shouldn't kipi-plugins have been
automatically removed too?

Am I doing this the wrong way:

office34:~ # rpm -q --whatrequires digikam
no package requires digikam




I'm not going to really *install* it for testing, I can only believe
zypper. And please do not forget that RPM --whatrequires is much more
literal and must be exact.

10:~ # zypper info --requires kipi-plugins
Loading repository data...
Reading installed packages...


Information for package kipi-plugins:
-------------------------------------
Repository: openSUSE-Leap-42.1-Update
Name: kipi-plugins
Version: 4.14.0-8.1
...
Requires:
...
digikam-libs
...
10:~ # zypper info --requires digikam-libs
Loading repository data...
Reading installed packages...


Information for package digikam-libs:
-------------------------------------
Repository: openSUSE-Leap-42.1-Update
Name: digikam-libs
Version: 4.14.0-8.1
Arch: x86_64
...
Requires:
...
digikam == 4.14.0
10:~ #

--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups